Bug 26677 - Installer hangs on test video setup with Matrox g450LE
Installer hangs on test video setup with Matrox g450LE
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-08 02:37 EST by Todd
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 10:58:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v (3.12 KB, text/plain)
2001-03-18 17:15 EST, David Sainty
no flags Details
XF86Config-4 file generated byXF86Config-4 file generated by Xconfigurator but with a different Modes line (1.66 KB, text/plain)
2001-03-18 17:16 EST, David Sainty
no flags Details
X messages from a successfulX output from successful 1792x1344 start-up (8.94 KB, text/plain)
2001-03-18 17:18 EST, David Sainty
no flags Details
lspci -nv (2.81 KB, text/plain)
2001-03-25 00:36 EST, Todd
no flags Details

  None (edit)
Description Todd 2001-02-08 02:37:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


graphical installer incorrectly identifies Matrox g450LE (single data 
rate, 16MB ) as g400. (Same chips different die size?) While it is quite 
easy to choose g450 from list subsequently choosing to test video setup 
causes flickering black and then hang.
Comment 1 Mike A. Harris 2001-02-08 14:23:25 EST
What does the output of "lspci -v" and "lspci -nv" say for the card.
It might have a different PCI id.
Comment 2 Todd 2001-02-09 02:45:38 EST
Sorry still working on getting that box working, when I do I can include 
complete output.
I assume the most relevant line in the result of lsci -v is
 MGA G400 AGP (rev82)
Comment 3 Todd 2001-02-10 01:21:24 EST
result of lspci -v with same hardware but different install

00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev
c4)
	Subsystem: ABIT Computer Corp.: Unknown device a204
	Flags: bus master, medium devsel, latency 8
	Memory at d0000000 (32-bit, prefetchable) [size=64M]
	Capabilities: <available only to root>

00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x
AGP] (prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, medium devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	Memory behind bridge: d6000000-d8ffffff
	Prefetchable memory behind bridge: d4000000-d5ffffff
	Capabilities: <available only to root>

00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev
40)
	Subsystem: ABIT Computer Corp.: Unknown device 0000
	Flags: bus master, stepping, medium devsel, latency 0
	Capabilities: <available only to root>

00:07.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06) (prog-if
8a [Master SecP PriP])
	Subsystem: VIA Technologies, Inc. Bus Master IDE
	Flags: bus master, medium devsel, latency 32
	I/O ports at c000 [size=16]
	Capabilities: <available only to root>

00:07.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16) (prog-if 00
[UHCI])
	Subsystem: Unknown device 0925:1234
	Flags: bus master, medium devsel, latency 32, IRQ 9
	I/O ports at c400 [size=32]
	Capabilities: <available only to root>

00:07.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 16) (prog-if 00 [UH
CI])
	Subsystem: Unknown device 0925:1234
	Flags: bus master, medium devsel, latency 32, IRQ 9
	I/O ports at c800 [size=32]
	Capabilities: <available only to root>

00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 4
	Flags: medium devsel
	Capabilities: <available only to root>

00:0a.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
	Subsystem: Netgear FA310TX
	Flags: bus master, medium devsel, latency 32, IRQ 10
	I/O ports at cc00 [size=256]
	Memory at da000000 (32-bit, non-prefetchable) [size=256]
	Expansion ROM at <unassigned> [disabled] [size=256K]

00:0e.0 Unknown mass storage controller: Triones Technologies, Inc. HPT366
03)
	Subsystem: Triones Technologies, Inc.: Unknown device 0001
	Flags: bus master, 66Mhz, medium devsel, latency 120, IRQ 11
	I/O ports at d000 [size=8]
	I/O ports at d400 [size=4]
	I/O ports at d800 [size=8]
	I/O ports at dc00 [size=4]
	I/O ports at e000 [size=256]
	Expansion ROM at <unassigned> [disabled] [size=128K]
	Capabilities: <available only to root>

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev
prog-if 00 [VGA])
	Subsystem: Matrox Graphics, Inc.: Unknown device 07c0
	Flags: bus master, medium devsel, latency 64, IRQ 5
	Memory at d4000000 (32-bit, prefetchable) [size=32M]
	Memory at d6000000 (32-bit, non-prefetchable) [size=16K]
	Memory at d7000000 (32-bit, non-prefetchable) [size=8M]
	Expansion ROM at <unassigned> [disabled] [size=128K]
	Capabilities: <available only to root>

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


Comment 4 David Sainty 2001-02-14 19:27:52 EST
I have access to a card here also, and can test any suggestions. This seems
related to #24505. I have made some progress with the 2.4.1-ac2 G450 frame
buffer patch. Current status on installed system using 2.4.1-ac2 G450 patch:

1. If I don't chosse frame-buffer support, machine starts up in standard text
mode. XFree86 (latest - 4.0.2-7) only starts in up to 800x600 mode. Any higher
freezes the system, requiring a cold reboot.

2. If I give vga=787 to the kernel, then consoles work fine with frame buffer.
Frame buffer + G450 now seems good. When I start up XFree86 with the matrox
driver, all resolutions are now good also. The problem is returning to a
frame-buffer text console from X. If I return from 800x600 X to the frame-buffer
text console, display is _good_. If I return from 640x480 display is distorted
but mostly viewable. If I return from anything else like 1024x768, I get whacky
sync values which don't work on the monitor. The machine never freezes however,
and doing a <Ctrl><Alt><F7> to return to X brings correct display back.

Machine is a Dell Precision 420. Monitor is 17" Dell CRT.
Comment 5 David Sainty 2001-02-17 20:48:51 EST
Okay, now testing with kernel 2.4.1-0.1.8 (enterprise) and XFree86-4.0.2-9 with
the two mga latest .o's from the Matrox site dated 8th Feb 2001:

http://www.matrox.com/mga/support/drivers/files/linux_05.cfm

Without frame buffer specified (i.e. no vga=xxx option passed to kernel), normal
text startup occurs. When X starts, there is no machine freeze, unlike with the
standard XFree86-4.0.2-9. Resolutions seem to work properly inside of X (640x480
-> 1280x1024). When I return to a text console, I get almost correct display,
but there is something not quite right - the resolution reported by the Dell
monitor is 640x350@70Hz instead of 720x400@70Hz (which is what you get on boot
up). Another problem is if I kill X a couple of times (with <Ctrl><Alt><Bspce>)
then X seems to screw up severely and basically lock the system.

With frame buffer (vga=787) specified, the machine starts up fine. X also starts
fine. When we change to a frame buffered text console from X, we get exactly the
same results as with the standard XFree86-4.0.2-9 except that there is text
discolouration, similar to that reported in #27147. Switching to text from
800x600 gives good text, above this gives invalid modes. Again as with for no
frame buffer support, killing X twice in a row freezes the machine.

Comment 6 Mike A. Harris 2001-03-17 19:39:07 EST
Once again, to the original poster, I need the info I asked for, you gave half
of it.

lspci -vn

This gives me the PCI sub device numbers which distinguish a G450 from a G400
There may be more than one subid and we only have one in our pcitable, so
without this info I cannot compare.  Time is very critical for you to send this
info right now, so try to get it to me ASAP, and if it differs, I will add
it to the pcitable db.

Also..  please run these commands as root, not as a user.
Comment 7 David Sainty 2001-03-18 17:10:11 EST
Okay...  kernel 2.4.2-0.1.29, XFree86-4.0.3-1....

Text (non Frame Buffer)
------------------------------
Running Xconfigurator produces the XF86Config-4 file that I will post. Using
this freezes the machine when the card attempts to change modes and display the
new X screen.

Given a report that a G450 _did_ work with the XF86Config file generated by
"XFree86 -configure", I proceded to try this and was amazed to find the G450
working perfectly(!!) - in 1792x1344 resolution!  I decided to compare
differences between the two XF86Config files (one form XFree86 -configure and
the other from Xconfigurator). After much messing around, the problem was the
_Modes_ line. If you specify ANY resolution in the Modes line other than
1792x1344, the machine FREEZES.  If you elimate the Modes line from the
Xconfigurator produced XF86Config(-4) things work fine. Things also work fine if
you add a "Modes "1792x1344"" line.

So, what we see is that with the latest rawhide, my G450 ONLY works (without
kernel frame buffer support) if you start X in 1792x1344 resolution.  You can
specify "Modes "1792x1344" "1024x768"", etc and swap between resolutions inside
X, successfully, so long as X starts initially from text in 1792x1344 mode. 
FYI, the mode is 1792x1344, 204.8MHz 83.7kHz 60.0Hz.  (Starting X in 1792x1344,
changing X to 1024x768, for example, going back to text, then returning to X
will also freeze the computer since you have a text -> non 1792x1344 transition.)

Frame Buffer (vga=788)
-----------------------------
When we use vga=788, we can start X in any resolution successfully, from the
frame buffer text console. We can also swap between X resolutions successfully.
The problem with frame buffer is as noticed previously - swapping back to text
mode when X is in any resolution / mode other than that used by frame buffer,
results in the video card using a broken mode.  That is, the active X mode
directly affects the new mode for the frame buffer text, when changing back to
frame buffer from X.

Summary
-------------------
The problem with the driver as it stands appears to be related to setting the
mode to be used. There appear to be dependency problems between the previous
mode used and the new mode being selected.  It also appears as though there may
be to a certain extent a case of saying G450 "works" prematurely, just because
the card works with the "default" mode used by XFree86 v4.0.2/3.

More information
---------------------------
G450 card used:   Matrox G45+ MDHA32D/DEL (Dell, 32MB, Dual Head)
Model No. DP/W 0608UX  Rev. A00     (card came in Dell Precision 420)

I will attach the lspci -v from the machine, the XF86Config-4 file generated by
Xconfigurator but with a different Modes line, and X messages from a successful
1792x1344 start-up.

Other related G450 reports are #24505, #30648 and #29530.
Comment 8 David Sainty 2001-03-18 17:15:37 EST
Created attachment 12944 [details]
lspci -v
Comment 9 David Sainty 2001-03-18 17:16:57 EST
Created attachment 12945 [details]
XF86Config-4 file generated byXF86Config-4 file generated by Xconfigurator but with a different Modes line
Comment 10 David Sainty 2001-03-18 17:18:28 EST
Created attachment 12946 [details]
X messages from a successfulX output from successful 1792x1344 start-up
Comment 11 Todd 2001-03-25 00:36:42 EST
Created attachment 13583 [details]
lspci -nv
Comment 12 Todd 2001-03-25 00:39:55 EST
sorry about the delay,
as requested, please find attachment id=13583 above containing the results 
of /sbin/lspci -nv
Comment 13 Mike A. Harris 2001-03-28 01:46:13 EST
Ok great.  I've acquired a list of all G450 PCI ID's now and sent
them to Bill.  I'm reassigning to kudzu since that is where the pcitable
data is kept.  It will most likely appear in the next kudzu rawhide drop.
Comment 14 Bill Nottingham 2001-03-28 10:58:33 EST
These are in CVS; assigning back to X for the driver issues.
Comment 15 Mike A. Harris 2001-05-15 06:02:15 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.