Bug 267 - mput function doesn't work properly at times
Summary: mput function doesn't work properly at times
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ftp   
(Show other bugs)
Version: 5.2
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-02 20:16 UTC by ah313
Modified: 2013-11-14 09:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-04 19:28:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ah313 1998-12-02 20:16:19 UTC
The mput feature of the FTP client doesn't work very well
on slow connections (due to packet loss).  When you do
a mput *, the client has a tendancy to skip over
the odd file from time to time.  File permissions isn't
a problem.

Actually the FTP server gets the request to send the next
file from the client, the server prints the message
"READY TO RECIEVE...", and then the client at times
just doesn't send the file, and sends the next file
successfully with no problems.  Rarely do 2 files in a
row get skipped, but I've seen it once...

Comment 1 Jeff Johnson 1998-12-04 19:28:59 UTC
The behavior you are seeing has to do with packet loss
rather than the implementation of "mput". While running
an mput command, a network error will cause files to be skipped.


Note You need to log in before you can comment on or make changes to this bug.