Bug 267041 - Window Maker with 4 wakeups
Window Maker with 4 wakeups
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: WindowMaker (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
http://www.ift.unesp.br/users/crmafra
:
Depends On:
Blocks: wakeup
  Show dependency treegraph
 
Reported: 2007-08-30 09:46 EDT by Carlos R. Mafra
Modified: 2007-12-20 15:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-09 12:38:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Substitute polling with kernel's dnotify mechanism (5.15 KB, patch)
2007-08-30 09:46 EDT, Carlos R. Mafra
no flags Details | Diff
Remove timer which calls delayedAction (503 bytes, patch)
2007-08-30 09:51 EDT, Carlos R. Mafra
no flags Details | Diff
Remove useless timer (1.03 KB, patch)
2007-08-30 09:55 EDT, Carlos R. Mafra
no flags Details | Diff
Compile with gcc 4 (from mandriva) (5.39 KB, patch)
2007-08-30 09:58 EDT, Carlos R. Mafra
no flags Details | Diff

  None (edit)
Description Carlos R. Mafra 2007-08-30 09:46:41 EDT
Description of problem:
Window Maker is responsible for 4 wakeups when totally idle (as shown by
powertop). 


Version-Release number of selected component (if applicable):
wmaker-0.92.0 (from www.windowmaker.info website)

How reproducible:
I am not a Fedora user (sorry), but I bet that wmaker also wakes up approx.
4 times in the latest fedora.

Steps to Reproduce:
1. Run wmaker without any dockapps running
2. Start powertop on a xterm and stand still (no mouse movement, no key presses,
etc)
3. 
  
Actual results:
wmaker appears with 3.5 to 4 wakeups

Expected results:
It should have 0 wakeups when totally idle, as it should be event driven.

Additional info:
Two months ago I've made a patch for my own usage (see this post in powertop
list:
http://www.bughost.org/pipermail/power/2007-June/000614.html)
and I've been using my own version of wmaker with 0 wakeups since then, with
no known regression or any problems.

On my website (url provided above) I have this patch, plus an additional one 
from mandriva to make the vanilla wmaker-0.92.0 compile with gcc 4. Well, I 
divided the wakeup patch into 3 separated patches, according to what it does.

The -remove_nopolling.patch is more evolved, since it replaces the default
behavior of polling whether the configuration files inside ~/GNUstep/Defaults
have changed by the kernel dnotify mechanism. Note that I adapted the dnotify
example from the kernel source Documentation/dnotify.txt to my needs. With this
patch wmaker is notified when the conf. files changed. E.g., if I modify the
WMRootMenu by hand, or with the genmenu script (also on my webpage, but someone
else wrote the script under GPL), wmaker automatically loads the new menu.

The other two patches just remove what I _think_ are useless timers. However,
I am not so sure (theoretically) what the delayedAction function really does,
except that by removing the timer which calls it (with
-remove_delayedAction.patch) I experimentally don't see any bad side effects. 

Well, I hope these patches turn out to be useful for someone. They are for me.
I really like not seeing wmaker in powertop's shame list.
Comment 1 Carlos R. Mafra 2007-08-30 09:46:41 EDT
Created attachment 181001 [details]
Substitute polling with kernel's dnotify mechanism
Comment 2 Carlos R. Mafra 2007-08-30 09:51:03 EDT
Created attachment 181041 [details]
Remove timer which calls delayedAction
Comment 3 Carlos R. Mafra 2007-08-30 09:55:28 EDT
Created attachment 181061 [details]
Remove useless timer
Comment 4 Carlos R. Mafra 2007-08-30 09:58:32 EDT
Created attachment 181081 [details]
Compile with gcc 4 (from mandriva)
Comment 5 Andreas Bierfert 2007-08-30 11:11:17 EDT
Thanks for submitting your patches. I don't see a general problem with wakeups
(come on ... it does not hurt your battery that much ;) ) I will try to
integrate it into the wmaker package for fedora. As we don't really have a devel
tree at the moment I will wait till the f8 release, do some testing here locally
in the meantime and add it to rawhide/f9 asap. If it works well and there are no
complains I will consider issuing upgrades for f8 and f7.
Comment 6 Andreas Bierfert 2007-12-09 12:38:28 EST
Build for devel.
Comment 7 Fedora Update System 2007-12-10 15:43:07 EST
WindowMaker-0.92.0-15.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update WindowMaker'
Comment 8 David Rees 2007-12-13 19:18:27 EST
I can confirm that WindowMaker-0.92.0-15.fc8 eliminates wakeups from wmaker.

Will this also be pushed to Fedora 7? I have a machine running F7 and
WindowMaker that could use this.
Comment 9 Fedora Update System 2007-12-20 15:14:15 EST
WindowMaker-0.92.0-15.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.