Bug 26713 - Cannot recompile kernel from kernel-2.2.16-3.src.rpm
Cannot recompile kernel from kernel-2.2.16-3.src.rpm
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-08 15:14 EST by Forrest
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 17:11:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Forrest 2001-02-08 15:14:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


Running Redhat 6.2 with all updates on a PIII 1GHz (single processor).  
This is related to bug # 21798 & # 18240.  I looked for the linux-2.2.16-
rhconfig.patch, but it does not exist in the -3 src.  I also removed 
the /boot/kernel.h and linux/configs directory, to no avail.
Any attempt to recompile the kernel from the SRPM or the kernel-source RPM
fails as follows:

make: Entering directory `/usr/src/redhat/BUILD/linux/ibcs/iBCSemul'
kgcc -D__KERNEL__=1 -DMODULE -D__NO_VERSION__ -I../include
-I/usr/src/redhat/BUILD/linux/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -m486 -DSOCKSYS_MAJOR=30  -DEMU_SCO -DEMU_ISC
-DEMU_SVR4 -DEMU_BSD -DEMU_WYSE -DEMU_WYSEMP -DEMU_SPX -DEMU_XTI
-DEMU_TLI_OPTMGMT -DEMU_BINFMT_AOUT -DEMU_BINFMT_COFF -DEMU_BINFMT_XOUT
-DEMU_BINFMT_OLDSCRIPT -DIBCS_TRACE -DVERBOSE_ERRORS -DCOFF_TRACE
-DELF_TRACE -DXOUT_DEBUG -DMODVERSIONS -include
/usr/src/redhat/BUILD/linux/include/linux/modversions.h -D__SMP__=1 -c
emulate.c
/usr/src/redhat/BUILD/linux/include/asm/smp.h: In function
`hard_smp_processor_id':
In file included from /usr/src/redhat/BUILD/linux/include/linux/smp.h:11,
                 from /usr/src/redhat/BUILD/linux/include/linux/sched.h:20,
                 from /usr/src/redhat/BUILD/linux/include/asm/uaccess.h:8,
                 from emulate.c:43:
/usr/src/redhat/BUILD/linux/include/asm/smp.h:209: warning: implicit
declaration of function `GET_APIC_ID'
/usr/src/redhat/BUILD/linux/include/asm/smp.h:209: `APIC_BASE' undeclared
(first use in this function)
/usr/src/redhat/BUILD/linux/include/asm/smp.h:209: (Each undeclared
identifier is reported only once
/usr/src/redhat/BUILD/linux/include/asm/smp.h:209: for each function it
appears in.)
/usr/src/redhat/BUILD/linux/include/asm/smp.h:209: `APIC_ID' undeclared
(first use in this function)
../include/ibcs/ibcs.h: At top level:
In file included from emulate.c:61:
../include/ibcs/ibcs.h:47: warning: function declaration isn't a prototype
make: *** [emulate.o] Error 1
make: Leaving directory `/usr/src/redhat/BUILD/linux/ibcs/iBCSemul'
Bad exit status from /var/tmp/rpm-tmp.943 (%build)

Reproducible: Always
Steps to Reproduce:
1.rpm -ba kernel-2.2.16.spec or any variation of this (e.g. rpm -bb --
target=i686 kernel-2.2.16.spec).
2.
3.
	

Actual Results:  Error in ibcs.h

Expected Results:  It should have built the kernel/src rpm packages
Comment 1 Forrest 2001-02-08 15:48:26 EST
Oops, I was copying from another source;
kgcc -D__KERNEL__=1 -DMODULE -D__NO_VERSION__ -I../include  should be:
cc -D__KERNEL__=1 -DMODULE -D__NO_VERSION__ -I../include
Comment 2 Forrest 2001-02-08 17:11:49 EST
I tried installing the smp kernel (with my uniprocessor), and booting to it to 
no avail.

I looked at the command that was giving this error:
make -j 1 -C ibcs/iBCSemul KERNEL=/usr/src/redhat/BUILD/linux SMP=yes all

I took the SMP=yes out, and reran the command from BUILD/linux, and it worked.
I then took out the SMP=$1 under the IBCS header in kernel-2.2.16-3.spec, and 
it seems to be working.  Does anyone know what this does???
Comment 3 Michael K. Johnson 2001-02-09 17:04:17 EST
I haven't reproduced this with our errata kernel.

Note You need to log in before you can comment on or make changes to this bug.