Bug 267361 - userpasswd fails immediately on startup
userpasswd fails immediately on startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
7
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
http://forums.fedoraforum.org/forum/s...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 10:59 EDT by Matt Wette
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.93-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 12:44:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
user account - immediately after entering userpasswd (9.81 KB, image/jpeg)
2007-08-31 18:23 EDT, Stefan Zakarias
no flags Details
user account - clearing dialog box (16.33 KB, image/jpeg)
2007-08-31 18:26 EDT, Stefan Zakarias
no flags Details
root account - weak password (6.32 KB, image/jpeg)
2007-08-31 18:35 EDT, Stefan Zakarias
no flags Details
root account - the dialog that follows a when a weak password is entered. Entering anything here is not accepted. (17.92 KB, image/jpeg)
2007-08-31 18:39 EDT, Stefan Zakarias
no flags Details
My system-auth (887 bytes, text/plain)
2007-09-04 10:59 EDT, Stefan Zakarias
no flags Details

  None (edit)
Description Matt Wette 2007-08-30 10:59:05 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
If I click from menu bar [System]->[Preferences]->[Personal]->[About Me]
and then click "Change Password" I get an error that the password typed
is incorrect, even before I type anything. This is the way it comes up. Then
if I close the error pop-up and type in my password, nothing happens.

Steps to Reproduce:
1. start gnome-about-me
2. click on "Change Password"
3. click "OK" to close error message
  
Actual results:
when "Change Password" is clicked error dialog comes up
after error dialog is closed, nothing happens

Expected results:
expect to see form to change password

Additional info:
this was posted on fedoraforum.  At least one other on i386 reported same problem
Comment 1 Matt Wette 2007-08-30 11:00:29 EDT
component is control-center-2.18.0-20.fc7
Comment 2 Stefan Zakarias 2007-08-30 12:18:33 EDT
I'll just confirm that it happens on 32bit as well (so there's no distinction
between 32/64bit).  Using Gnome 2.18.3-1.fc7.
Comment 3 Ray Strode [halfline] 2007-08-31 09:55:03 EDT
what happens if you run userpasswd?
Comment 4 Stefan Zakarias 2007-08-31 18:23:19 EDT
Created attachment 184081 [details]
user account - immediately after entering userpasswd

This is what is entered immediately after entering userpasswd from console
Comment 5 Stefan Zakarias 2007-08-31 18:26:01 EDT
Created attachment 184121 [details]
user account - clearing dialog box

After clearing dialog box, you are left with this dialog where it doesn't
matter what you type because the box will close with no changes done.
Comment 6 Stefan Zakarias 2007-08-31 18:35:46 EDT
Created attachment 184141 [details]
root account - weak password

The weak password error meassage
Comment 7 Stefan Zakarias 2007-08-31 18:39:25 EDT
Created attachment 184161 [details]
root account - the dialog that follows a when a weak password is entered.  Entering anything here is not accepted.
Comment 8 Stefan Zakarias 2007-08-31 18:43:54 EDT
Comment on attachment 184161 [details]
root account - the dialog that follows a when a weak password is entered.  Entering anything here is not accepted.

Entering anything here is not accepted.
Comment 9 Stefan Zakarias 2007-08-31 18:47:37 EDT
userpasswd from a 'root' account with a strong password, everything works as
expected.
Comment 10 Ray Strode [halfline] 2007-09-04 09:59:59 EDT
Can you attach your /etc/pam.d/system-auth ?

This is either a problem with userpasswd or pam.

reassigning
Comment 11 Stefan Zakarias 2007-09-04 10:59:25 EDT
Created attachment 186231 [details]
My system-auth
Comment 12 Miloslav Trmač 2007-09-04 20:52:31 EDT
Fixed in usermode-1.93.  Thanks for your report.
Comment 13 Stefan Zakarias 2007-09-05 21:11:20 EDT
(In reply to comment #12)
> Fixed in usermode-1.93.  Thanks for your report.

Thank you for your time and expediency in resolving this bug.  I'll confirm if
this bug is fixed when it becomes available in the RPM updates or earlier when
it becomes available in testing.
Comment 14 Stefan Zakarias 2007-09-07 04:02:05 EDT
I pulled the following RPMs from Koji:

usermode-1.93-1.fc7.i386.rpm
usermode-gtk-1.93-1.fc7.i386.rpm

Installed them and everything seems to be working as expected :)

Thank you, Miloslav, for fixing this.  All the best mate :)
Comment 15 Fedora Update System 2007-09-07 13:16:37 EDT
usermode-1.93-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2007-09-12 12:44:42 EDT
usermode-1.93-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.