Bug 26761 - core dump during boot up.
core dump during boot up.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-08 19:14 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 19:14:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-08 19:14:49 EST
I am running:
Red Hat Version 6.2
(I believe it is the Deluxe version,
but not sure.)
AMD 1Ghz processor
ASUS A7Pro motherboard
Matrox G450 Video Card
Intel 100/Pro Management Network card
128 megs of memory.

I installed Red Hat linux using server
install, however during the initial
boot sequence. After it tries to disable
the processor ID.
I get swapping failed. a display of
my registers and memory.

I installed a promo copy of
Storm Linux 2000, which booted up
correctly.  I would prefer to use Red Hat
though.
Comment 1 Doug Ledford 2001-02-09 06:32:01 EST
This is caused by the default kernel trying to disable serial numbers in the
processor, which your AMD processor doesn't have and is resulting in a processor
fault.  The 2.2.16-3 and later kernel errata for Red Hat Linux 6.2 have a fix
for this in place already.  In order to boot your machine up, at the lilo prompt
type:

linux x86_serial_nr

to cause the kernel to not try and disable CPU serial numbers on your AMD CPU. 
That way you can then upgrade your kernel, or you can add the x86_serial_nr
option as an append item in your lilo.conf file so that you don't have to
upgrade kernels, either way will solve the issue.

Note You need to log in before you can comment on or make changes to this bug.