Bug 26789 - Soundblaster AWE64 ISA PNP configuration problems
Soundblaster AWE64 ISA PNP configuration problems
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-09 02:28 EST by Casey Keller
Modified: 2014-03-16 22:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 17:16:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ISAPNP from PROC directory (3.61 KB, text/plain)
2001-04-21 12:57 EDT, Casey Keller
no flags Details

  None (edit)
Description Casey Keller 2001-02-09 02:28:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1 i586; Nav)


When trying to use sndconfig to setup my Soundblaster AWE64 ISA PNP, I
cannot get
a working setting.  I have tried all combinations of IRQs and DMAs, etc. 
Event the old
settings I used on Redhat 6.2 does not work for fisher.  When attemping a
sound test I get a small piece of the test wav then nothing.

Reproducible: Always
Steps to Reproduce:
1.Run sndconfig for an AWE64 card.
2.Attempt to adjust the settings when the first attempt does not work.
3.Test new settings.
	

Actual Results:  Small clip of the wav files plays.  The midi works fine.

Expected Results:  Well, should have heard LInus's full speech.

To even be sure it was not the 2.4.0.....kernel module that comes with
Fisher, I downloaded and compiled the 2.4.1 release from kernel.org.  The
results were the
same.
Comment 1 Glen Foster 2001-02-09 18:16:48 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Bill Nottingham 2001-02-12 17:32:39 EST
Are you saying that the initial PnP-chosen settings don't work - do they
have the same problem (only play a short bit of the sound), or do they
give a different errror?
Comment 3 Bill Nottingham 2001-03-08 17:56:27 EST
I've tried this here with an AWE64 PnP, and it works OK. Please try this
with the sndconfig/kudzu RPMs at
  http://people.redhat.com/notting/sndconfig/

and re-open if it persists.
Comment 4 Casey Keller 2001-04-02 16:11:27 EDT
Problem persists in Wolverine Beta as well.

Looking over the isapnp.conf file shows with IRQ 5.  In previous distributions I
have been able to set to IRQ 7 or 10 to circumvent the problem.  The problem is
interrupt based.  

I have no other ISA cards except the sound card.  I even switched to a different
SB AWE64 with
no avail.  Both cards work well under 7.0 and under Mandrake.

I updated the sndconfig and kudzu as per your bugzilla report.  The new kudzu
did detect the card,
but still used an IRQ 5 setting.
Comment 5 Bill Nottingham 2001-04-02 16:47:22 EDT
The new kudzu/sndconfig don't use isapnp.conf; you should probably remove
yours. What is in /proc/isapnp?
Comment 6 Casey Keller 2001-04-21 12:57:57 EDT
Created attachment 15965 [details]
ISAPNP from PROC directory
Comment 7 Casey Keller 2001-04-21 13:04:05 EDT
Attached is the /proc/isapnp file.

I recently changed the box over to Linux-Mandrake 8.0 just to see the
difference, if any, in the problem.  The problem persists there as well and even
takes a moment longer to detect the card with sndconfig.

Any ideas?  I have checked out the file as well as /proc/pci and so worth to see
if there is an IRQ/DMA conflict.  None that I can see.
Comment 8 steven craig peterson 2001-08-20 21:13:22 EDT
in 7.0 i had the same problem when i got 7.1 it found my card but when i try to
play a sound my system locks up 
this problem is 100% reproducible
Comment 9 stuart 2002-02-18 22:30:02 EST
I also have an SB AWE64 ISA PNP.  It works perfectly in 
RH6.2 with kernels 2.2.16 and 2.2.19.  After upgrading
to RH7.2, audio stops working.  awe_wave still works if
I am careful not to load the sb driver.  uart401 even
works if I load the sb driver but am careful not to 
output any sound.
Trying to output sound results in the first buffer playing,
then lots of kernel CPU, plus garbage is dislayed on the
ASCII terminal attached to /dev/ttyS1 (!)
If I remove all isapnp configs and boot clean, then run
sndconfig, the sample plays correctly.  However, subsequent
uses produce the problem above.
If I add:
options sb isapnp=0 io=0x220 irq=10 dma=0 dma16=5 mpu_io=0x300
to modules.conf and modprobe sb, I get the error:
kernel: sb: dsp reset failed
/proc/isapnp shows 
Card 1 'CTL00e4:Creative SB AWE64  PnP' PnP version 1.0 Product version 1.0
  Logical device 0 'CTL0045:Audio'
    Device is not active
    Active port 0x220,0x300,0x388
    Active IRQ 10 [0x2]
    Active DMA 0,5

This same configuration, of course, works in kernel-2.2.19,
and I have tried various other configurations as well.
Comment 10 Guðmundur D. H. 2002-02-20 14:58:37 EST
I have a problem also, except that the card is not found at all.

What model is your card? Mine is CT4520. 
-G.
Comment 11 Guðmundur D. H. 2002-02-20 17:14:19 EST
Hmm, if any of you have the CT4520 model (you can see it if you open the box and
see the sticker on the card), then please try this: 

http://support.dell.com/us/en/kb/document.asp?DN=1036014
http://www.computing.net/windows95/wwwboard/forum/1488.html

It worked for me, and now the card works like a charm; it feels nice to have
Uriah Heep in the speakers again ;) (and Midi is back! :).

I wish to thank Jerome Cornet for pointing this out. :)

-G.

Comment 12 Bill Nottingham 2005-01-21 17:16:38 EST
sndconfig is no longer developed, and this release has reached end-of-life.
Closing out old bugs.

Note You need to log in before you can comment on or make changes to this bug.