Bug 26797 - Apache dependencies broken?
Apache dependencies broken?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-09 04:00 EST by Telsa Gwynne
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 18:04:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2001-02-09 04:00:33 EST
text mode upgrade from a previous beta cycle.
Whilst flicking through the list of packages
to be installed, came across apache, wondered
why I wanted a webserver, and unselected it
(left mod_* unselected too). I forgot I'd
installed it for some reason previously.

It didn't complain about dependencies, so I got
this on boot/shutdown:

* Starting http...                       [FAILED]
Cannot load /etc/httpd/modules/libphp3.so into server: /etc/httpd/mod
ules/libphp3.so: cannot open shared object file: No such file or directory.

Not sure whether this is broken dependencies or my fault
for not upgrading it and then leaving it running. Feel free
to close if I'm being stupid :)
Comment 1 Nalin Dahyabhai 2001-02-15 00:15:25 EST
Since PHP3 wasn't included in RHL7 or Fisher, I suspect that you've got an old
httpd config file.  Is there or was there an old PHP3 package installed?
Comment 2 Telsa Gwynne 2001-02-15 06:09:09 EST
$ rpm -qa | grep php
php-4.0.4pl1-4
$ grep php /tmp/upgrade.log
Upgrading php.
(There's a list of what it didn't install/upgrade following)
I subsequently upgraded apache and the error above went away.
Looking in /etc/httpd/conf, there's now httpd.conf and httpd.conf.rpmsave
so I guess this is my fault for not having upgraded apache with everything
else in the first place. I had forgotten it was on the machine, so I thought
I wouldn't bother installing it :)
Comment 3 Ben Levenson 2001-02-15 17:34:58 EST
FWIW-here is some information from my boot.log
build: qa0215.1
upgraded Everything install 6.2 --> 7.1beta.

Feb 15 10:17:21 test104 httpd: Syntax error on line 250 of
/etc/httpd/conf/httpd.conf:
Feb 15 10:17:21 test104 httpd: Cannot load /etc/httpd/modules/mod_php.so into
server: libgd.so.1: cannot load shared object file: No such file or directory
Feb 15 10:17:21 test104 httpd: httpd startup failed
Comment 4 Nalin Dahyabhai 2001-02-16 12:28:24 EST
hobbit, I'll probably mark this as WORKSFORME, but benl's problem looks slightly
different.

benl, do you have the 'phpfi' package installed?
Comment 5 Ben Levenson 2001-02-20 15:38:41 EST
yup.
# rpm -qa|grep php
php-4.0.4pl1-6
php-ldap-4.0.4pl1-6
php-manual-4.0.4pl1-6
php-imap-4.0.4pl1-6
php-pgsql-4.0.4pl1-6
phpfi-2.0.1-12
Comment 6 Nalin Dahyabhai 2001-02-23 15:09:47 EST
Okay, so the problem is that while PHP 4 obsoleted PHP 3, it didn't obsolete
phpfi.  Fixed in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.