Bug 26802 - RFE: Don't force user to create swap partitions, or allow swap file
RFE: Don't force user to create swap partitions, or allow swap file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-09 04:09 EST by Ed McKenzie
Modified: 2007-03-26 23:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 12:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-02-09 04:09:43 EST
There are situations where dedicating an entire partition to swap is not
really the best way to install. Anaconda should give the option of not
having swap at all, or, if it's going to force swap, at least give the
option of putting it in a file on a mounted filesystem.
Comment 1 Michael Fulbright 2001-02-11 22:13:15 EST
Noted as a future feature request.
Comment 2 Brent Fox 2001-05-04 16:19:06 EDT
Although I think these situations are pretty rare.
Comment 3 Need Real Name 2001-05-13 14:14:54 EDT
I don't think is pretty rare, bfox...

anaconda forces me to create a swap partition even if I:

- want to use rh7.1 as a desktop
- have 256MB ram
- want to use a *file* based swap

/sergio
ps: yes, I know a swap partition give me more performance.
ps2: maybe rh should introduce a new "Desktop" category when installing
Comment 4 Alexei Podtelezhnikov 2001-05-14 14:24:35 EDT
I don't see how the requirement to have a swap partition blocks fresh
installation of rh 7.1. It seems that someone just doesn't want it. Thus,
that someone can later reconfigure/reformat the system, or do whatever 
he wants with the swap partition. The purpose of installation is to get the
system running with as little trouble as possible. It does not have to please
someone with incredibble flexibility in the form of a hundred options, and annoy
all others by making them spend too much time configuring.
Comment 5 Need Real Name 2001-05-23 09:29:35 EDT
i had (1)a system  with 2 HD, one with Redhat Linux 7.1  (8GB disk having two 
partitions, c and d  , as to dos) and the second one was the backup hd (15 GB 
FAT32) i intalled Linux onto the first HD first partition letting Linux create 
whatever it needs, swaps . fully automatically... then it installed itself 
sucessfully in the first try.. the second time i needed to intall some more 
packages which would take more time searching and installing in the Server 
version, so i decided to overwrite the existing Server version with the 
Workstation version of Linux.. so i let it go again full automatically.. it 
again installed itself sucessfully  but with a fatal difference.. later i 
leraned that it formatted my backup HD instead of installing itself on to the 
existing Linux system... That was a true disaster !!!!!!!!!  it could at least 
ask or could say "Overwrite existing Linux"....  that was inacceptable bug of 
all bugs...   i will no longer try any Linux version... :((((
Comment 6 Ed McKenzie 2001-05-23 11:57:33 EDT
If swapless isn't going to be an option, I'd be happy if the option to create a 
swapfile on the FS (see upgrade screens) were also available for new installs.  
Installing recent RH is really a pain on machines that also run Solaris and 
NT.  Forcing me to change the partition table has me doing silly things like 
installing on a different machine and tarring the entire filesystem over to the 
NT boxes;  first, anaconda has no problem trashing anything that looks like a 
swap partition, e.g. solaris slices, and then NT doesn't like some of the 
strange partition tables disk druid creates.  It's pretty easy to break the NT 
loader by creating out-of-order partitions on the boot drive.  (There are some 
machines where repartitioning and reinstalling everything else is not an 
option.)

So much for interoperability. In any case, partitions aren't resizable without 
reinstalling and/or lots of pain, so I'd think swapfiles would be the preferred 
option, given that it really doesn't make any difference performance-wise.

Anyway, those looking for a workaround might install RH5.x if your hardware is 
supported, then upgrade to 7.
Comment 7 Bryce Nesbitt 2001-06-19 13:23:28 EDT
I agree with this bug report ( I just logged on to make a similar request ).
I want to create a swap-free installation.  I just got around this by
temporarily "lying" about the type
another partition.  Later, after turning swap off, I'll format the partition
like I really want it.

RedHat works great without a swap.  Why do the installation scripts insist I
have one?
If the script would just SHUTUP and let me procede, everything would be fine.

		-Bryce


(Note that the text mode install says "you must have at least one 150M partition
to install".
That's wrong.  Because of this issue you must have two partitions.
Comment 8 Matt Wilson 2001-07-23 23:59:40 EDT
done for next release.

Note You need to log in before you can comment on or make changes to this bug.