Bug 2682 - locate won't work with amd running
locate won't work with amd running
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: findutils (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
: 2717 3410 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-09 06:59 EDT by _eemeli_
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-01 15:25:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description _eemeli_ 1999-05-09 06:59:57 EDT
When running amd on RH Linux 6.0, command updatedb will
never finish, and so datebase is not updated. Could be also
caused by netfs and/or autofs.
Comment 1 Jeff Johnson 1999-05-15 18:31:59 EDT
*** Bug 2717 has been marked as a duplicate of this bug. ***

When using updatedb to create the locate database, it locks
up on empty directories. At first it seemed to be taking an
extremely long time, but when running it with -v, it became
obvious the it was getting locked up on certain directories.
When a file was placed in the directory, it would continue
without any problems
Comment 2 Jeff Johnson 1999-05-15 18:33:59 EDT
*** Bug 2728 has been marked as a duplicate of this bug. ***

Don't know if this is a bug, but locate acts strange now and
then, so...

I notice that updatedb keeps on running (forever?)
"ps aux" shows:

updatedb(bdflush)

Should there be something excluded in slocate? Or is this
behaviour normal?

Thanks,

Stef.

------- Additional Comments From notting@redhat.com  05/11/99 10:35 -------
that's update (bdflush), which is the kernel's cache
flushing-daemon. It doesn't have anything to do with
slocate.

------- Additional Comments From stef.pillaert@kahosl.be  05/12/99 03:10 -------
OOPS!! Very sorry!
But the reason I got confused was: running "updatedb" (and not
slocate, sorry) hangs. (and I thought it was launched at startup, and
confused it with update)

Should I exclude something from updatedb?
Thanks.

Stef.

------- Additional Comments From notting@redhat.com  05/13/99 11:04 -------
If you do 'strace -o output updatedb', and then look at
the output file when it hangs, where is it hanging?
Comment 3 Jeff Johnson 1999-06-01 14:58:59 EDT
I've replace updatedb in slocate-1.6-1 to more perfectly imitate
the behavior of the findutils updatedb. This means that certain
directories and NFS or smb mount points will not be searched while
building the slocate database.
Comment 4 Jeff Johnson 1999-06-12 13:15:59 EDT
*** Bug 3410 has been marked as a duplicate of this bug. ***

slocate doesn't complete it's daily run. After about a day,
it is still running, gobbling up the complete CPU, and
pushing up the load. Dunno what's causing it, ps aul shows
it's not doing anything in the kernel.

Can't seem to find slocate in the list of components, so
thought I might try this approuch instead... :)

Note You need to log in before you can comment on or make changes to this bug.