Bug 268201 - Problems updating the rpm package
Problems updating the rpm package
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 13:54 EDT by Dwight Tovey
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-03 09:34:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dwight Tovey 2007-08-30 13:54:02 EDT
Description of problem:
There seems to be a versioning problem when updating a machine from FC6 to F7. 
My machine was FC6 with the latest updates as of Aug 29, 2007 applied.  Today
(Aug 30, 2007) I upgraded the system to F7 using the DVD.  The upgrade went OK,
but after rebooting when I went to run 'pup' I got a "No module named rpm"
error.  On digging around Google and others, I found that the error traced back
to 'yum' and the versions of 'rpm*' that were installed.  During the upgrade to
F7, yum had been updated to the F7 version.  However, the rpm packages were
still at FC6 versions:

# rpm -qa | grep ^rpm
rpm-libs-4.4.2.1-1.fc6
rpm-4.4.2.1-1.fc6
rpm-python-4.4.2.1-1.fc6

When I tried to run 'rpm -U' to upgrade the rpm packages (plus the popt
dependancy) I got:
        package popt-1.10.2.1-1.fc6 (which is newer than popt-1.10.2-46.fc7) is
already installed
        package rpm-libs-4.4.2.1-1.fc6 (which is newer than
rpm-libs-4.4.2-46.fc7) is already installed
        package rpm-4.4.2.1-1.fc6 (which is newer than rpm-4.4.2-46.fc7) is
already installed
        package rpm-python-4.4.2.1-1.fc6 (which is newer than
rpm-python-4.4.2-46.fc7) is already installed

I believe these errors are why the FC6->F7 upgrade did not apply the rpm updates.  

I'm not sure if the FC6 version really was newer than the F7 version on the DVD,
but since this condition prevents pup and yum from running, this could be a
significant problem

I was able to resolve the problem by using the '--force' flag to rpm to install
the F7 versions of the rpm packages.


Version-Release number of selected component (if applicable):
See above

How reproducible:
Always

Steps to Reproduce:
1. Install FC6
2. Use 'pup' to apply latest FC6 updates
3. Upgrade to F7 using DVD
4. Run 'yum'
  
Actual results:
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   No module named rpm

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.5 (r25:51908, Apr 10 2007, 10:29:13) 
[GCC 4.1.2 20070403 (Red Hat 4.1.2-8)]

If you cannot solve this problem yourself, please go to 
the yum faq at:
  http://wiki.linux.duke.edu/YumFaq


Expected results:
Loading "installonlyn" plugin
You need to give some command
Usage: yum [options] < grouplist, localinstall, groupinfo, localupdate,
resolvedep, erase, deplist, groupremove, makecache, upgrade, provides, shell,
install, whatprovides, groupinstall, update, repolist, groupupdate, info,
search, check-update, list, remove, clean, grouperase >

Options:
  -h, --help            show this help message and exit
  -t, --tolerant        be tolerant of errors
...


Additional info:
Comment 1 Panu Matilainen 2007-09-03 09:34:55 EDT
Download the 4.4.2.1 rpm packages from F7 updates and install them to get it
working.

The F7 DVD has been created a long time ago so it can (and does) have older
versions of various things than those on an up-to-date FC6 installation.
You have to do a network installation with updates of the new distribution
enabled to avoid this - can't be helped. Or well, could be helped by forcing a
distro policy never to update older version packages to newer than what's on
released DVD/CD images. Might work for RHEL, not so for Fedora.
Comment 2 Dwight Tovey 2007-09-06 11:25:33 EDT
I understand that the F7 DVD can have older versions than the latest FC6. 
That's to be expected of any installation/update process.  My main purpose for
opening the bug was to provide some documentation for the next person who runs
into this. However, the install (or an update) should not leave the system in a
broken state.  As it was, I could not run 'pup' or 'yum' because of the version
problems with the rpm* packages.  Maybe this should be a bug against the install
process or 'yum' instead of rpm.

Note You need to log in before you can comment on or make changes to this bug.