Bug 268301 - yum crash
yum crash
Status: CLOSED DUPLICATE of bug 253394
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
i686 Other
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 14:33 EDT by Boris Goldowsky
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 15:12:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
transaction-all- from /var/lib/yum (4.00 KB, application/octet-stream)
2007-08-31 14:42 EDT, Boris Goldowsky
no flags Details
transaction-done- from /var/lib/yum (4.00 KB, text/plain)
2007-08-31 14:42 EDT, Boris Goldowsky
no flags Details

  None (edit)
Description Boris Goldowsky 2007-08-30 14:33:36 EDT
Description of problem:
Yum crashes after installing large number of packages.

Version-Release number of selected component (if applicable):
yum-3.2.4-3.fc8


How reproducible: happened once


Steps to Reproduce:
1. yum install emacs eclipse

Actual results:

Yum crashes after installing all, but before any cleanup steps

[...]
  Installing: eclipse-pde-sdk              ####################### [91/92] 
  Installing: eclipse-sdk                  ####################### [92/92] 
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 180, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 382, in doTransaction
    self.runTransaction(cb=cb)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 571, in
runTransaction
    errors = self.ts.run(cb.callback, '')
  File "/usr/lib/python2.5/site-packages/yum/rpmtrans.py", line 249, in callback
    self._instCloseFile(  bytes, total, h )
  File "/usr/lib/python2.5/site-packages/yum/rpmtrans.py", line 311, in
_instCloseFile
    self.ts_done(txmbr.po, txmbr.output_state)
  File "/usr/lib/python2.5/site-packages/yum/rpmtrans.py", line 164, in ts_done
    (t,e,n,v,r,a) = self._te_tuples[0] # what we should be on
IndexError: list index out of range

Additional info:
Comment 1 Boris Goldowsky 2007-08-30 15:14:31 EDT
Sorry, version number reported above is not correct.  Actual version installed
at time of this error was 3.2.3-2.fc8 .
Comment 2 Seth Vidal 2007-08-30 22:04:47 EDT
if you could - go look in /var/lib/yum and send me any files you find there, please.

thanks
Comment 3 Boris Goldowsky 2007-08-31 14:42:07 EDT
Created attachment 183781 [details]
transaction-all- from /var/lib/yum
Comment 4 Boris Goldowsky 2007-08-31 14:42:41 EDT
Created attachment 183801 [details]
transaction-done- from /var/lib/yum
Comment 5 Jeremy Katz 2007-09-13 15:12:34 EDT

*** This bug has been marked as a duplicate of 253394 ***

Note You need to log in before you can comment on or make changes to this bug.