Bug 26840 - crash on boot with "Aiee, killing interrupt handler"
Summary: crash on boot with "Aiee, killing interrupt handler"
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-09 16:19 UTC by jim schwarz
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-16 04:34:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jim schwarz 2001-02-09 16:19:26 UTC
using the pcmcia boot disk and installing from ftp.redhat.com, redhat 
linux 7.0 crashes on boot. redhat 6.2 worked fine

Reproducible: Always
Steps to Reproduce:
0.get a dell latittude lt, 64MB RAM, 1GHD, no partitions, no CD
1.boot from pcmcia boot disk
2.install redhat server 7.0 from ftp.redhat.com	

after successful overnight install, reboot

crash

Code: 8b 4a 04 85 etc.
Aiee, killing interrupt handler

Comment 1 Matt Wilson 2001-02-09 16:36:53 UTC
Is there any way tou can copy more of the oops into this report?  The call trace
section is especially important.


Comment 2 Matt Wilson 2001-02-09 16:37:39 UTC
Also, at what point in the boot process does this crash occur?  When starting
PCMCIA services?


Comment 3 jim schwarz 2001-02-09 17:07:48 UTC
the crash is right at the initializing pcmcia services section of boot.
how much of what is on the screen should i enter here? i.e. how much of the "*" 
do you need?

my screen has this on it:

78>]*
0d>]*
f6>]*
7a>]*
6d>]*
4e>]*
60>]*
4e>]*
27>]*
78>]*
Code: 8b 4a 04 85 c9 74 22 8b 5a 18 8b 02 89 01 8b 0a 85 c9 74 08
Aiee, killing interrupt handler

Comment 4 Matt Wilson 2001-02-09 17:45:49 UTC
The first line at the Call Trace: section should be enough to start.


Comment 5 jim schwarz 2001-02-09 18:21:37 UTC
here are the last two lines:

27>] [<c01dab4e>][c010f560>]
       [<c01dab4e>] [<c010a06d>] [<c011157a>][<c01dacf6>] [<c0117a0d>] [<c010a4
78>] [<c01d9227>][<c01dab4e>]
       [<c010f560>] [<c01dab4e>] [<c010a06d>] [<c011157a>] [<c01dacf6>]
Aiee,...


Comment 6 Need Real Name 2001-03-16 04:34:04 UTC
I also get a crash on boot using a Dell Latitude C800. It occurrs immediately 
after the PCMCIA service is started. I get this not metter whether the card is 
inserted or not.

Code: 8b 4e 08 83 f9 ff 0f 84 a7 00 00 00 89 c8 25 ff 01 00 00 8b
Aiee, killing interrupt handler ...


Note, I also got a similiar error after installing Mandrake 7.2.

    Rgds


    Phil

Comment 7 Matt Wilson 2001-03-16 04:48:37 UTC
This will be fixed in the next release - the following in
/etc/pcmcia/config.opts needs to be changed from:

include port 0x100-0x4ff, port 0x800-0x8ff, port 0xc00-0xcff

to

include port 0x100-0x4ff, port 0xc00-0xcff


Comment 8 Need Real Name 2001-03-16 05:55:59 UTC
I have changed the config.opts file to reflect the different port

i.e. include port 0x100-0x4ff, port 0xc00-0xcff

however, I am still getting the boot crash. 

I hashed out that line completely and used a different range as described in 
the PCMCIA-Howto

i.e. include port 0x100-0x4ff, port 0x1000-0x17ff
     include memory 0x80000000-0x80ffffff

I have also excluded irq 3 and 5 as per the HOWTO, but have not had success.

This laptop has 256 MB of RAM. Will that make a difference to where the pcmcia 
resource window is? Any other ideas for me to try?


Comment 9 Matt Wilson 2001-03-16 05:57:59 UTC
is your pci router detected?


Comment 10 Need Real Name 2001-03-16 06:22:38 UTC
I don't think so because there is no /proc/pci file.

Also when I run /etc/init.d/pcmcia status I get 

   ./pcmcia: pidof: command not found
   cardmfg is stopped



Note You need to log in before you can comment on or make changes to this bug.