Bug 268601 - snd-hda-intel not working
snd-hda-intel not working
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 15:31 EDT by Dave Cross
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.6.22.5-76.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 17:58:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/dmesg as requested (23.21 KB, text/plain)
2007-08-30 17:19 EDT, Dave Cross
no flags Details

  None (edit)
Description Dave Cross 2007-08-30 15:31:33 EDT
Description of problem:

kernel-2.6.22.4-65.fc7 is missing the snd-hda-codec.ko file from
/lib/modules/2.6.22.4-65.fc7/kernel/sound/pci/hda/. This prevents sounds from
working on an Intel sound chip that uses snd-hda-intel.

Version-Release number of selected component (if applicable):

Last worked correctly on 2.6.21-1.3194.fc7. All versions since then are missing
the file.

How reproducible:

Boot computer with Intel sound chip using any recent kernel rpm. Try to open
volume control applet.

Steps to Reproduce:
1. Boot computer using (for example) kernel-2.6.22.4-65.fc7
2. Click on volume control icon in gnome bar
  
Actual results:

Error - "No volume control GStreamer plugins and/or devices found". No sound on
system.

Expected results:

Volume control opens. System has sound.

Additional info:
Comment 1 Chuck Ebbert 2007-08-30 16:01:02 EDT
snd-hda-codec has been merged into snd-hda-intel.

Please post contents of /var/log/dmesg after booting with the non-working kernel
on the affected system.
Comment 2 Dave Cross 2007-08-30 17:19:01 EDT
Created attachment 182101 [details]
/var/log/dmesg as requested

Note line 466 "hda-intel: no codecs initialized"
Comment 3 Chuck Ebbert 2007-08-30 17:43:43 EDT
Fix for this should be in 2.6.22.5-76, appearing in the updates-testing repo soon.

Note You need to log in before you can comment on or make changes to this bug.