Bug 268761 - elfutils 129 doesn't find zero sized symbols
elfutils 129 doesn't find zero sized symbols
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 173278
  Show dependency treegraph
 
Reported: 2007-08-30 15:54 EDT by Andrew Cagney
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.131-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 19:13:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Cagney 2007-08-30 15:54:49 EDT
It is related to this:
  /* Keep track of the lowest address a relevant sizeless symbol could have.  */
  GElf_Addr min_label = addr;
when there's no sized symbol containing addr preventing this:
  /* If we found no proper sized symbol to use, fall back to the best
     candidate sizeless symbol we found, if any.  */
  if (closest_name == NULL
      && sizeless_name != NULL && sizeless_sym.st_value >= min_label)
from applying.

my assembler looks like either:

# A global symbol that has zero size.
GLOBAL(global_st_size_0)
        LOAD_IMMED_BYTE (REG0, 0)
        STORE (REG0, REG0)  <--------- addr is here
        NO_OP
# A local symbol that has zero size.
LOCAL(local_st_size_0)
        LOAD_IMMED_BYTE (REG0, 0)
        STORE (REG0, REG0)  <--------- addr is here
        NO_OP

a simple example though is _start.
Comment 1 Roland McGrath 2007-08-30 16:07:16 EDT
This report needs: exact raw assembly source, what machine to assemble it on, a
test scenario using eu-addr2line -S with particular addresses, actual output
seen, and expected output.
Comment 2 Roland McGrath 2007-10-16 05:57:55 EDT
This issue should be resolved by elfutils-0.130.  If there is still a problem,
reopen or file a new bug report with complete test case details.
Comment 3 Fedora Update System 2007-10-17 22:30:54 EDT
elfutils-0.130-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update elfutils'
Comment 4 Fedora Update System 2007-11-12 19:13:22 EST
elfutils-0.131-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.