Bug 26902 - rpm-4.0-6x seems completely busted
Summary: rpm-4.0-6x seems completely busted
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-10 01:18 UTC by henry
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-10 08:10:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description henry 2001-02-10 01:18:15 UTC
I upgraded from the version of RPM that came on Red Hat 6.0 (rpm-3.0 I
believe) to rpm-4.0-6x and rpm-devel-4.0-6x so that I could install some
things that came in the new format RPMs.  This worked fine, including the
--rebuilddb and the install of the new RPMs, but the resulting rpm
command seems incapable of building RPMs from source.
I.e.,
	rpm -bp spec-file
fails with a general usage message for rpm.  Thus I can now not do
ANYTHING with my source RPMs.  By comparison, the rpm-4.0-4 installed
under Red Hat 7.0 works fine (although I don't want to try and install
it on my 6.0 machine because it needs Python 1.5.2 which I can't switch
to yet).
PLEASE: come out with a version of rpm-4 that works under Red Hat 6.x.
I'm getting desparate.

Comment 1 Jeremy Katz 2001-02-10 08:09:54 UTC
Did you install the rpm-build package?  This is necessary in order to be able to
build packages with rpm 4.0.x

Comment 2 Jeff Johnson 2001-02-10 13:11:48 UTC
What he said :-)

Yes, all the build modes in rpm-4.0 are in a separate executable called
/usr/bin/rpmbuild contained in the rpm-build package.

Comment 3 henry 2001-02-10 17:39:41 UTC
I have not seen any rpm-build which is part of the rpm-4.0-6x family.
Note, with the older rpm that came with Red Hat 6.0, everything was in
rpm and rpm-devel.  If this exists, could you please tell me where it
is?
I don't think that another rpm is going to help.  Observe the behavior
or rpm that came in rpm-4.0-6x: if you run
	rpm -bp xxx
it complains with a generic usage message as if it didn't understand the
-bp option.  If you do this with a working rpm then it will complain
that xxx doesn't exist.  It looks to me like the command line argument
processing is busted.
Am I being fooled?


Comment 5 henry 2001-02-11 02:08:05 UTC
Ah, that fixed it.  rpm-build didn't exist on Red Hat 6.0, only
rpm and rpm-devel.
Note, with only rpm-4.0-6x and rpm-devel-4.0-6x, I got only a
usage message as if it didn't understand the -bp argument.
In general I like RPMs, including making my own, but the error
messages when things go wrong are not so great.
Any way, thanks again.


Note You need to log in before you can comment on or make changes to this bug.