Bug 26929 - virtual host config doesn't work as expected
Summary: virtual host config doesn't work as expected
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apacheconf   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-10 07:42 UTC by Jeremy Katz
Modified: 2015-03-05 01:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-13 14:24:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2001-02-10 07:42:00 UTC
apacheconf-0.63-1.  Creation of virtual hosts seems to not take the
"Default Virtual Host" into account as the actual default if you define
more than one virtual host.  This is due to invalid setup of the
VirtualHost section in /etc/httpd/conf/httpd.conf.  Relevant part of
httpd.conf (with blank lines removed)

# Virtual host Default Virtual Host
<VirtualHost >
        ServerName _default_
        DirectoryIndex index.php index.html index.htm index.shtml
        ServerSignature email
        LogLevel warn
        HostNameLookups off
</VirtualHost>


This should be <VirtualHost _default_:*> iirc.

Comment 1 Glen Foster 2001-02-12 23:10:16 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 2 Phil Knirsch 2001-02-13 14:41:26 UTC
Fixed and included suggested default values as well.


Note You need to log in before you can comment on or make changes to this bug.