Bug 26933 - xscreensaver when locked can be exited
xscreensaver when locked can be exited
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 82708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-10 05:44 EST by zehekel
Modified: 2014-03-16 22:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-10 05:44:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zehekel 2001-02-10 05:44:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; m18)
Gecko/20001107 Netscape6/6.0


when running gnome and putting locking the system with the xscreen saver.
anyone can exit gnome and be returned to the command prompt by by pressing
ctrl-alt-backspace.  this command should work when in xwindows, but seem
odd to allow this when the system is locked with a password.  seems to
defeat the purpose of even having a password on the screen saver.

Reproducible: Always
Steps to Reproduce:
1.boot to command prompt under user or root account
2.enter gnome gui with "startx"
3."lock screen" by pushing the "lock screen" button and have xscreensaver
password protected.
4. after screen saver is running press ctrl-alt-backspace
5. xwindows will terminated and give a working command prompt, hence no
password protection.
	

Actual Results:  xwindows exited and the command prompt worked fine.

Expected Results:  i would have thought that this command would have been
disabled so the only way to exit the screen saver would be with the correct
password.
Comment 1 Bill Nottingham 2001-02-11 02:59:41 EST
This is impossible to do from the screensaver, AFAIK.
Comment 2 zehekel 2001-02-11 03:19:39 EST
I have just installed a fresh copy of Linux 7.0 download from Red Hats own
site.  I burned the iso, did the automatic install for a gnome workstation. 
When the screen saver is active xwindows CAN be exited, with the
ctrl-alt-backspace command.  This is 100% reproduceable, which seems to conflict
with the resolution of "This is impossible to do from the screensaver" actually
its quite possible and quite easy to do.  The only non 7.0 component that I am
running is the my XFree86-SVGA component which had to be down graded to 3.3.6-20
to work with my S3 Savage4 pro video card.  I hope that these bugs are actually
tested....
Comment 3 Bill Nottingham 2001-02-11 03:30:42 EST
What I'm saying is that it's impossible to disable that key combination
from the screensaver.
Comment 4 Bill Nottingham 2002-11-26 00:16:20 EST
*** Bug 78597 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2003-01-24 23:11:20 EST
*** Bug 82708 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.