Bug 26955 - pcmcia-cs ignores wireless.opts
pcmcia-cs ignores wireless.opts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-10 12:21 EST by Alan Shutko
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 10:26:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New /etc/pcmcia/config file for aironet (41.76 KB, text/plain)
2001-02-21 10:11 EST, Erik Troan
no flags Details

  None (edit)
Description Alan Shutko 2001-02-10 12:21:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-0.99.11 i686; en-US; 0.7)
Gecko/20010118


The current /etc/pcmcia/network script has no knowledge of wireless.opts.
This means that it won't work out of the box on my wireless network, which
requires encryption.

Reproducible: Always
Steps to Reproduce:
1. Buy wireless access point.
2. Turn on encryption
3. Follow PCMCIA docs on putting "key" in wireless.opts
4. Watch card not connect with AP.
	

Note that the upstream version of pcmcia/network now handles RH network
scripts perfectly fine, so it would be good to revert to its behavior,
which also gives the possibility to use schemes.
Comment 1 Glen Foster 2001-02-12 18:14:17 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Erik Troan 2001-02-21 10:11:15 EST
Created attachment 10620 [details]
New /etc/pcmcia/config file for aironet
Comment 3 Erik Troan 2001-02-21 10:12:14 EST
I attached a new pcmcia-config to this bug which should fix this problem. Plesae
test it and let me know if it works.

Arjan, can you take a gander at it and make sure everything looks right for the
airo stuff as well?
Comment 4 Alan Shutko 2001-02-21 10:21:11 EST
Huh?  Did you close the wrong bug?  This wasn't an aironet-specific bug (I don't
even have an aironet card).  This was that we aren't executing
/etc/pcmcia/wireless and /etc/pcmcia/wireless.opts, because the RH-modified
network script doesn't call them.  wireless.opts is important, because I can set
all sorts of iwconfig options there and do it with schemes, so that I can easily
switch between WEP-encrypted networks.

Again, the upstream scripts now know about redhat and will call ifup and ifdown,
but will also work with network.opts and wireless.opts, solving this bug.
Comment 5 Erik Troan 2001-02-21 10:26:20 EST
Yeah, I closed the wrong bug :-( Now I need to track that one down.

I'll look at using the standard pcmcia network script tomarrow when I'm closer
to my laptop.
Comment 6 Erik Troan 2001-02-27 12:15:22 EST
While the standard network script seems quite similiar to ours, using it would
force us to maintain two. Instead, I changed the network script we're using to
run the normal pcmcia-cs wireless script before running our own ifup stuff. This
should solve the problem nicely.

Note You need to log in before you can comment on or make changes to this bug.