Bug 26971 - cannot copy from tk clients (exmh, fetchmailconf) to paste to gnome-terminal
Summary: cannot copy from tk clients (exmh, fetchmailconf) to paste to gnome-terminal
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Ben Levenson
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-10 18:18 UTC by Anvil
Modified: 2007-04-18 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-29 20:34:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anvil 2001-02-10 18:18:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0 i686; en-US; 0.7) Gecko/20010118


It seems that i cannot make copy/paste from exmh to gnome-terminal.. I
can copy/paste from exmh to emacs or to xterm but not to
gnome-terminal.. I can also copy/paste from emacs to gnome-term.. so as
a work around i can copy/paste from exmh -> emacs -> gnome-terminal..
While writing this mail i also tried to copy/paste from fetchmailconf to
gnome-term and it didn't work too.. fetchmailconf & exmh are both tk
clients..


Reproducible: Always
Steps to Reproduce:
1. gnome-terminal &
2. fetchmailconf &
3. select some text in fetchmailconf with the mouse and try to paste it in the gnome-teminal	
	

Actual Results:  nothing happens..

Expected Results:  The text is pasted in gnome-terminal

The bug was not present in guinness.. This may be gnome-core issue or tk issue

Comment 1 Havoc Pennington 2001-02-12 17:01:13 UTC
Are you pasting to gnome-terminal with middle mouse or with the Paste menu item?
Does one work and not the other? See
http://www.freedesktop.org/standards/clipboards.txt, this is probably a Tk bug.


Comment 2 Havoc Pennington 2001-02-13 01:05:00 UTC
Nevermind, the problem is that gnome-terminal was patched to use the
COMPOUND_TEXT target instead of the STRING target for paste as part of Japanese
multibyte support, this is incorrect, it needs to support both targets.
I'll fix this - it should be MUST-FIX as it will cause interoperability issues
with many clients.

Comment 3 Havoc Pennington 2001-02-19 19:26:20 UTC
Should be fixed in  gnome-libs-1.2.8-8

Comment 4 Kjartan Maraas 2004-03-29 20:34:53 UTC
Closing as fixed UPSTREAM. 1.x is no longer supported anyway.


Note You need to log in before you can comment on or make changes to this bug.