Bug 2700 - filesystem does not get unmounted correctly
filesystem does not get unmounted correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
alpha Linux
low Severity low
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-10 13:15 EDT by Jay Turner
Modified: 2015-01-07 18:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 14:31:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 1999-05-10 13:15:36 EDT
When performing a cd or hard drive installation without
enough free diskspace, user will get message telling him the
amount of additional space necessary.  Upon hitting <back>
in order to adjust the package selection, user will get
dialog telling him that the device or resource is busy.
This is because the filesystem was not unmounted when the
user hit <back>  Hitting <retry> from the error dialog will
unmount the filesystem correctly and allow the user to
continue with the installation/upgrade.
Comment 1 Bill Nottingham 1999-05-10 17:50:59 EDT
*** Bug 2693 has been marked as a duplicate of this bug. ***

Example of bug occuring:

1.  Select packages which take up more disk space than you
    already have.

2.  When you are warned about this, go BACK to re-select
    packages.

An error, "Unable to mount..." (something) appears.  This
isn't fatal, the install goes on as normal.  It looks as if
the installer is trying to mount a partition that is
already mounted.

RH6.0/Intel, FTP install.

------- Additional Comments From notting@redhat.com  05/10/99 10:05 -------
known bug. Hit 'retry' and you should be able to proceed.

------- Additional Comments From Tristan.Greaves@icl.com  05/10/99 10:20 -------
Hitting RETRY does indeed allow the installation to continue
successfully, but the error dialog box still allows dread to enter
the heart of the user. :-)
Comment 2 Bill Nottingham 1999-05-10 17:52:59 EDT
*** Bug 2301 has been marked as a duplicate of this bug. ***

If there's not enough space on the target drive and
the user chooses to go back and fix the package selections
a bit, the installer does not unmount /tmp/hdimage as it
probably should. Currently, the user has to unmount it
before proceeding to package installation, otherwise the
installer reports the device as busy and cannot continue.

------- Additional Comments From msw@redhat.com  04/27/99 11:16 -------
Please verify with 6.0
Comment 3 Jay Turner 2000-02-10 14:31:59 EST
This issue is fixed in the 6.1 release.

Note You need to log in before you can comment on or make changes to this bug.