Bug 27011 - RFE: Anaconda cannot create usernames that contain more than 8 characters
RFE: Anaconda cannot create usernames that contain more than 8 characters
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-10 23:54 EST by Nitebirdz (Jesus Ortega)
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 12:39:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nitebirdz (Jesus Ortega) 2001-02-10 23:54:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)


During the installation, the user is prompted to create additional user
accounts if he/she wants to.  If one tries to create a new user account
with a username that contains more than 8 characters, the following error
is displayed:

"User IDs must be less than 8 characters and contain only characters
A-Z, a-z, 0-9"

I see two problems with this behavior:

1) In spite of UNIX traditions, it is possible to create usernames that
contain more than 8 characters these days.  Red Hat Linux allows to create
such accounts once the installation is completed, and therefore for
consistency sake it should also allow it during the installation process.

2) If we allow the installer to make it impossible to create these
accounts, then the error message should be changed since the ID doesn't
need to be "less than 8 characters long" but rather 8 or less.  The wording
would need to be changed then.

Reproducible: Always
Steps to Reproduce:
1.  Try to create an account whose username contains more than 8 characters
during the installation.
Comment 1 Michael Fulbright 2001-02-11 23:00:50 EST
Brent - check into if we need to change this limit.
Comment 2 Brent Fox 2001-02-16 22:39:12 EST
We probably should change this so that usernames can be more than 8 chars, but
we can't change the labels at this time because of the translations.  I'll mark
this as RFE and put it on our list for future releases.  Marking as deferred.
Comment 3 Brent Fox 2001-09-21 15:29:36 EDT
Fixed in cvs.

Note You need to log in before you can comment on or make changes to this bug.