Bug 27029 - glibc-2.2-12 breaks IBM DB2 6.1 in Websphere 3.5
Summary: glibc-2.2-12 breaks IBM DB2 6.1 in Websphere 3.5
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-11 05:48 UTC by Chris Egolf
Modified: 2016-11-24 15:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-11 21:44:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Egolf 2001-02-11 05:48:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-pre1 i686)


On a clean RH7.0 installation with all the RH7.0 updates applied, including
glibc-2.2-12, the IBM DB2 6.1 included with IBM Websphere 3.5 (and 3.022)
breaks the 'db2' command line operations.  Reverting the system back to
glibc-2.2-9 packages fixes the problem.

Reproducible: Always
Steps to Reproduce:
1. Install RH7.0
2. Apply all updates for RH7.0 ('rpm -Fvh *.rpm')
3. Install IBM Websphere 3.5, specifically DB2 6.1
4. Try to start the DB2 engine -- generates error, but starts.
5. Try to run the DB2 command line utilities for the DB2 instance -- 
generates error and fails

Actual Results:  Trying to start the DB2 engine results in the following:
[root@cartman /root]# su - db2inst1
[db2inst1@cartman db2inst1]$ db2start
SQL2071N  An error occurred while accessing the shared library 
"libdb2licm.so". Reason code: "".
SQL1063N  DB2START processing was successful.

Trying to start the db2 command line tool results in the following:
[db2inst1@cartman db2inst1]$ db2
db2: error while loading shared libraries:
/usr/IBMdb2/V6.1/lib/libdb2.so.1: undefined symbol: __strtoq_internal


Expected Results:  [root@maul /root]# su - db2inst1  
[db2inst1@maul db2inst1]$ rpm -qa | grep "^glibc"
glibc-devel-2.2-9
glibc-2.2-9
[db2inst1@maul db2inst1]$ db2start
SQL1063N  DB2START processing was successful.

Here's an example of using the db2 command line tool:
[db2inst1@maul db2inst1]$ db2 create db was
DB20000I  The CREATE DATABASE command completed successfully.


The same version of IBM DB2 is included with Websphere 3.022 as well.

Comment 1 Jakub Jelinek 2001-02-11 21:44:29 UTC
Fix sent as http://sources.redhat.com/ml/libc-hacker/2001-02/msg00073.html
Apparently __strtou?q_internal aliases used to be used and thus
should not be removed for binary compatibility.

Comment 2 Jakub Jelinek 2001-08-08 13:19:25 UTC
Oops, forgot to close this. It is fixed since glibc-2.2.2-1.


Note You need to log in before you can comment on or make changes to this bug.