Bug 27049 - SSH closing connection before output is read
SSH closing connection before output is read
Status: CLOSED DUPLICATE of bug 21607
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-11 08:48 EST by Petr Tuma
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 10:07:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Tuma 2001-02-11 08:48:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-22 i686; en-US; m18)
Gecko/20010131 Netscape6/6.01


After updating to OpenSSH 2.3.0p1, I noticed the connection in "single
command" invocation mode (when I use "ssh <hostname> <command>" gets closed
the moment the command at the server finishes, which means that anything
output at the end of the command gets lost. This breaks some of the scripts
where I use commands such as "REMOTE_TIME=`ssh remote_host date`".


Reproducible: Always
Steps to Reproduce:
Just try to execute a short command, such as date or ls, on a remote
server. The link I tried it on was something like 100ms roundtrip, I do not
know if it matters though. What you should see is the client not getting
any output, although the command gets executed.
Comment 1 Pekka Savola 2001-02-12 16:17:51 EST

*** This bug has been marked as a duplicate of 21607 ***

Note You need to log in before you can comment on or make changes to this bug.