Bug 270521 - yum does not honor per-repo proxy-setting when retrieving repodata
yum does not honor per-repo proxy-setting when retrieving repodata
Status: CLOSED DUPLICATE of bug 191864
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All All
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-08-31 04:07 EDT by Thorsten Leemhuis
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 15:14:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2007-08-31 04:07:06 EDT
Description of problem:
At work we have a odd network setup -- we can connect via http-protocol only
over a squid proxy (e.g. outgoing via port 80 is blocked for normal systems).

No big deal as such, but I also have internal repos, which are not accessible
for the proxy. Thus I configured yum to not use the proxy for the internal repos
-- seems that is not honored when fetching metadata.

Version-Release number of selected component (if applicable):
yum-3.2.2-1.fc7

How reproducible:
Always

Additional info:

My repo-file:
---
[internal]
name=internal -- generic 
baseurl=http://foo/pub/repo/generic/$basearch/
enabled=1
proxy=_none_
metadata_expire=1
gpgcheck=0
---
# export http_proxy=http://squid.domain.de:8080
# yum update --disablerepo=* --enablerepo=internal
Setting up Update Process
http://foo/pub/repo/generic/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error
503: Server: squid/2.6.STABLE5
Date: Fri, 31 Aug 2007 08:00:48 GMT
Content-Type: text/html
Content-Length: 912
Expires: Fri, 31 Aug 2007 08:00:48 GMT
X-Squid-Error: ERR_DNS_FAIL 0
X-Cache: MISS from squid.domain.de
X-Cache-Lookup: MISS from squid.domain.de:8080
Via: 1.0 squid.domain.de:8080 (squid/2.6.STABLE5)
Proxy-Connection: close

Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: internal

# unset http_proxy
# yum update --disablerepo=* --enablerepo=internal
[works as expected]
Comment 1 Thorsten Leemhuis 2007-09-01 07:45:05 EDT
(In reply to comment #0)
> Description of problem:
> At work we have a odd network setup -- we can connect via http-protocol only
> over a squid proxy (e.g. outgoing via port 80 is blocked for normal systems).

Forgot: I'm not 100% sure, but I think I ran into the similar problem with other
yum-configurations on F7 or RHEL5 before. E.g. if I have all repos apart from
one available internally I configured the proxy only for the one repo that needs
it. That failed, as yum was not able to get the mirrorlists from the server, as
it didn't use the proxy for that step. I can test this again on F7 or RHEL5 if
more details are needed. 
Comment 2 Jeremy Katz 2007-09-13 15:14:20 EDT
proxy=_none_ doesn't work right in urlgrabber..

*** This bug has been marked as a duplicate of 191864 ***

Note You need to log in before you can comment on or make changes to this bug.