This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 27058 - Installer fails to set active partition properly (boot order wrong).
Installer fails to set active partition properly (boot order wrong).
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-11 12:53 EST by Ed McKenzie
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 15:30:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-02-11 12:53:08 EST
This box has two off-board disk controllers (Initio SCSI and Promise ATA,
both with a combination of disks and CD-ROMs), and anaconda fails to create
a lilo.conf that can successfully boot the system. The Promise card is the
boot device, as it's first in PCI order and gets assigned BIOS drives C and
D. However, anaconda sets boot=/dev/sda (E:) in lilo.conf. Incidentally,
the kernel too lists sda first in /proc/partitions, which is wrong.
Changing the boot order in the BIOS doesn't seem to affect this ordering.

After installation, the system can't be booted, as there aren't any active
partitions and anaconda has installed LILO on the wrong MBR.
Comment 1 Michael Fulbright 2001-02-11 22:59:54 EST
What is the device name(s) for the drives on the Promise card?
Comment 2 Ed McKenzie 2001-02-11 23:12:04 EST
full setup:

/dev/hdb - CD-ROM on primary slave (on-board controller, VIA MVP3)
/dev/hde - IBM Deskstar on primary master (Promise)
/dev/hdg - IBM Deskstar on secondary master (Promise)
/dev/sda - Seagate on ID0 (boot) of Initio 9100UW
/dev/scd0 - CD-RW on Initio
Comment 3 Michael Fulbright 2001-02-14 00:33:22 EST
What are the partitions/mount points you specified?
Comment 4 Ed McKenzie 2001-02-14 02:02:41 EST
/
	/dev/sda1
/boot
	/dev/hde1
/usr
	/dev/hde3
/home
	/dev/hde4
Comment 5 Michael Fulbright 2001-02-14 13:02:47 EST
Thanks I will look at this.
Comment 6 Michael Fulbright 2001-02-14 16:29:12 EST
This is something we will have to address in the future.  There is not currently
a mechanism to determine which drive is 0x80 as far as the BIOS is concerned.
Adding a UI interface to allow the user is not an option at this time because we
have frozen the UI.
Comment 7 Jeremy Katz 2002-01-21 19:59:32 EST
For future releases, you will be able to change the order of the drives if our
guess is not correct

Note You need to log in before you can comment on or make changes to this bug.