Bug 27076 - optical intellimouse mouse not working in GUI
Summary: optical intellimouse mouse not working in GUI
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
Whiteboard: Florence Gold
Depends On:
TreeView+ depends on / blocked
Reported: 2001-02-11 20:10 UTC by Sean Dilda
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-20 17:08:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Sean Dilda 2001-02-11 20:10:42 UTC
Using rawhide 20010211.
Mouse is a Microsoft Optical Intellimouse with the ps2 adapter used.

I'm doing a net install, once X starts (on the mouse selection screen), the
second I move the mouse, the cursor jumps to the top right of the screen
and stays there.  Moving the mouse produces no movement, except
occasionally the cursor jumps across the top of the screen, then
immediately back to the top right corner.

Comment 1 Michael Fulbright 2001-02-12 03:58:55 UTC
Dave do we have one of these to test?

Comment 2 Glen Foster 2001-02-12 23:11:04 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 3 Sean Dilda 2001-02-15 02:59:07 UTC
More information:

Tried the same mouse in usb mode (just didn't use ps2 adapter), and it worked
fine.  Also tested a normal ps2 intellimouse and it worked fine.

Also, I went through a test install with the Optical Intellimouse in ps2 mode. 
I told it I had a ps2 intellimouse and once the install had completed, X worked
fine with the mouse, this seems to only be a problem in anaconda.

Comment 4 Brent Fox 2001-02-20 04:21:33 UTC
Brock or Dave, do we have one of these mice in the test lab?

Comment 5 David Lawrence 2001-02-20 16:50:06 UTC
Nope. they are fairly new. We will need to order one.

Comment 6 Brent Fox 2001-02-20 17:08:21 UTC
Ok, putting in NEEDINFO state until it arrives.

Comment 7 Brent Fox 2001-02-28 15:51:16 UTC
The mouse has arrived.  I've done some tests and everything works fine for me
using both the USB and PS/2 ports.  Resolving as notabug.

Note You need to log in before you can comment on or make changes to this bug.