Bug 270841 - Doesn't suspend after a suspend action went wrong
Doesn't suspend after a suspend action went wrong
Status: CLOSED DUPLICATE of bug 442178
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 270821 270861
  Show dependency treegraph
 
Reported: 2007-08-31 07:02 EDT by Nils Philippsen
Modified: 2015-03-04 20:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-19 06:43:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2007-08-31 07:02:16 EDT
+++ This bug was initially created as a clone of Bug #270821 +++

Description of problem:

If a suspend action goes wrong, it may leave the /.suspended file on the next
boot which inhibits subsequent suspend/hibernate actions due to
take_suspend_lock() in /usr/lib/pm-utils/functions.

Version-Release number of selected component (if applicable):
pm-utils-0.99.3-6.fc7

How reproducible:
It depends.

Steps to Reproduce:
1. On a machine with broken suspend/hibernate (one of those not working should
be sufficient), run pm-suspend or pm-hibernate (whatever is broken, e.g. with an
old version of pm-utils with broken quirks)
2. After the action has sufficiently blown up in your face, reboot the machine
3. Run pm-suspend/-hibernate (whatever works, e.g. a new version of pm-utils
with fixed quirks
  
Actual results:
Machine switches to a VT and nothing else

Expected results:
Machine suspends/hibernates, stale /.suspended files get cleaned up some way. 

Additional info:
A stale /.suspended file doesn't even give an error message, that's really bad.
It should at least give that so the user had an idea what goes wrong. Then,
stale /.suspended should be detected so it doesn't inhibit subsequent
suspend/hibernate actions.
Comment 1 Till Maas 2008-04-19 06:43:27 EDT
This is fixed in pm-utils 1.0.6 together with initscripts-8.70-1.

*** This bug has been marked as a duplicate of 442178 ***

Note You need to log in before you can comment on or make changes to this bug.