Bug 2710 - Gnome panel apps stop working after Network Config tool is run
Gnome panel apps stop working after Network Config tool is run
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: control-panel (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-10 13:41 EDT by Jay Turner
Modified: 2015-01-07 18:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-19 21:36:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 1999-05-10 13:41:08 EDT
* run control-panel
* select Network Config Tool
* click <save>, which will close out Control-Panel and
return user to desktop
* no Gnome panel apps will run at this point
Comment 1 Jay Turner 1999-05-10 13:42:59 EDT
Restarting X is the only way to regain control of the panel apps.
NOTE: this situation only happens once.  Upon restarting X, user can
execute the same commands described above and the panel apps will not
freeze!
Comment 2 Michael K. Johnson 1999-09-19 21:36:59 EDT
This isn't all you are doing.  I'll bet that you are configuring and
starting a DHCP-enabled ethernet interface, which is changing the
hostname of the machine.  GNOME requires that the hostname remain
the same because the hostname is used in authentication.  Our
default X security method, xauth, is exactly the same.  There is
no simple way to fix this, and certainly no reasonable way that I
can think of.  It should not normally be an issue, as the ethernet
device will generally have already been set up (from install or
kudzu) and the hostname already set by the time X is running.

If my assumption about what you were doing is wrong, please
re-open with more details.

Note You need to log in before you can comment on or make changes to this bug.