Bug 27101 - Glide3 is a dependancy for install
Glide3 is a dependancy for install
Status: CLOSED DUPLICATE of bug 23861
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-02-11 20:48 EST by Kenneth Topp
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-31 04:26:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kenneth Topp 2001-02-11 20:48:46 EST
(and therefore kudzu).  I don't care to install Glide3, and I don't think
it should be a requirement.
Comment 1 Mike A. Harris 2001-02-11 21:47:48 EST
This is caused by an n'th complexity binary loop cascade scenario, which
is a known problem and will be dealt with in some future release of
Red Hat Linux.

Seriously, it will, I promise.  ;o)
Comment 2 Kenneth Topp 2001-02-12 14:13:31 EST
Well, I'm always interested to hear how this problem will be solved down the
road, but the problem (as I see it) is that I don't need Glide3 to install and
use XFree86 package.  It seems that you can make the Xconfigurator or what ever
software make this dependency, and us low diskspace users w/o 3d-hardware can
avoid installing that software.

That is, unless the dependecy is bogus altogether (as I have frequently found in
redhat packages).  I say that because I've installed the package and except for 
"Unsatisfied dependencies for XFree86-4.0.2-6: Glide3 >= 20001220" everything
behaves optimal.
Comment 3 Mike A. Harris 2001-02-13 00:50:59 EST
Glide is required by 3dfx cards in order for DRI to work properly on those
cards.  Since *ALL* of the drivers are in one package - the main package,
thus the main package is dependant on Glide.  Non-3dfx users can uninstall
Glide and won't have any trouble.  It is _NOT_ possible to split out each
driver into a separate package at this stage due to the amount of work
involved in doing so, and the timeframe - just to resolve a Glide dependancy.
I very much agree with you in every way however, and will ensure that a
future release has it fixed 'correctly'

Right now, the only acceptable solutions (to me) are:

1) Leave it as is and continue to DEFER bug reports until it can be fixed.
2) Build Glide in the XFree86 package directly, which is likely to generate
less complaints, but is only dodging the problem for now.

I've been trying to comfort people by ensuring that it will be fixed in the
future, but #2 is looking nicer every day due to the number of reports.
At least the way it is now, you can uninstall Glide after..

Comment 4 Mike A. Harris 2001-07-31 04:27:32 EDT

*** This bug has been marked as a duplicate of 23861 ***

Note You need to log in before you can comment on or make changes to this bug.