Bug 27145 - most files deleted from home directory
most files deleted from home directory
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-12 09:42 EST by Michael Young
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 09:42:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2001-02-12 09:42:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4u)


Something on my system deleted most of the files in my home directory,
though this excluded a chain of directories that where left containing only
a symbolic link. It is just over 10 days since these files where written,
and the deletion occured shortly after the machine was started, so I was
wondering whether it is possible that tmpwatch has started removing files
outside its specified area.

Reproducible: Didn't try
Comment 1 Preston Brown 2001-02-12 13:31:02 EST
no, this is impossible, unless you have changed /etc/cron.daily/tmpwatch script.
Comment 2 Michael Young 2001-02-12 14:15:31 EST
I haven't changed /etc/cron.daily/tmpwatch . However spontaneous deletion of
files is certainly a bug in my opinion, though I agree it is not necessarily
with tmpwatch. I was starting X at the time I noticed it, though the files
removed weren't all related to X/gnome. The files were deleted soon after I
started the machine up, as my initial login had the Redhat standard prompt, but
in a later login it had changed to "bash-2.04$".
It is also possible I had a symbolic link to my home directory in files in /tmp
in a saved copy of the home directory from a previous installation.
Comment 3 Michael Young 2001-02-13 13:10:52 EST
Running rpm -V on installed packages reveals a lot of files on the system that
have gone missing. I assume at least some of this deletion happened today as
various applications that worked yesterday are no longer working. I think you
may want to have another look at this bug report.

Note You need to log in before you can comment on or make changes to this bug.