Bug 271501 - cron.daily does not run
Summary: cron.daily does not run
Status: CLOSED DUPLICATE of bug 269961
Alias: None
Product: Fedora
Classification: Fedora
Component: crontabs   
(Show other bugs)
Version: 7
Hardware: All
OS: All
medium
urgent
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-31 14:44 UTC by Steven Stern
Modified: 2007-11-30 22:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 07:14:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steven Stern 2007-08-31 14:44:03 UTC
Description of problem:

crontab update breaks run-parts so cron.daily does not run

Version-Release number of selected component (if applicable):

crontabs.noarch 1.10-15.fc7 

How reproducible:

check logs

Steps to Reproduce:
1. update to crontabs.noarch 1.10-15.fc7 
2. wait until next morning
3. nothing happened

It appears some lines got added to /usr/bin/run-parts that caused the problem.

diff run-parts /usr/bin/run-parts
1a2,5
> # if cron.daily was run today
> AUX1=`cat /var/spool/anacron/cron.daily`
> AUX2=`date +%Y%m%d`
> [ "$AUX1" == $AUX2 ] || exit 0 
  
Actual results:


Expected results:


Additional info:

Comment 1 Nigel Metheringham 2007-09-01 07:53:06 UTC
That code appears to be intended to ensure cron.daily only runs once per day.
Instead it will only allow it to run on the same day as the last run!

Need to change
  [ "$AUX1" == $AUX2 ] || exit 0
to 
  [ "$AUX1" == $AUX2 ] && exit 0

For those people that run yum from cron.daily (like me), this will need
manual intervention to fix on each system and will prevent further automatic
updates INCLUDING SECURITY UPDATES until a release upgrade.

Comment 2 Nigel Metheringham 2007-09-01 07:56:04 UTC
Aaaaagh!!!

Didn't realise that this is in run-parts, not something specific to cron.daily

The additional code snippet must be removed entirely because its completely
castrated cron.hourly.  It may well break cron.weekly & cron.monthly because
all of them will look at the same cron.daily flag!


Comment 3 Nigel Metheringham 2007-09-01 08:01:41 UTC
This is a duplicate of Bug #269961

Comment 4 Marcela Mašláňová 2007-09-10 07:14:55 UTC
Fixed in crontabs-1.10-16.fc7

*** This bug has been marked as a duplicate of 269961 ***


Note You need to log in before you can comment on or make changes to this bug.