Bug 271701 - cman_tool leave remove doesn't reduce quorum
cman_tool leave remove doesn't reduce quorum
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.1
All All
medium Severity low
: rc
: ---
Assigned To: Christine Caulfield
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 11:06 EDT by Christine Caulfield
Modified: 2009-04-16 18:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:57:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix (4.72 KB, patch)
2007-08-31 11:36 EDT, Christine Caulfield
no flags Details | Diff

  None (edit)
Description Christine Caulfield 2007-08-31 11:06:47 EDT
Description of problem:

Running "cman_tool leave remove" on one node of a cluster does not reduce quorum
on the remainder of the cluster. So if you remove half the nodes, the cluster
will go inquorate and stall.


Version-Release number of selected component (if applicable):
5.0+

How reproducible:
Every time

Steps to Reproduce:
1. Start up a cluster
2. cman_tool leave remove half the nodes
  
Actual results:
cman_tool status shows quorum still at original value, and cluster is inquorate

Expected results:
cman_tool should reduce quorum and continue running.

Additional info:
Comment 1 Christine Caulfield 2007-08-31 11:36:17 EDT
Created attachment 183581 [details]
Patch to fix

I'm away until Thursday next week, so here's the patch if anyone fancies
testing it.
Comment 2 Christine Caulfield 2007-09-07 08:18:01 EDT
Checked into head of CVS

Checking in commands.c;
/cvs/cluster/cluster/cman/daemon/commands.c,v  <--  commands.c
new revision: 1.70; previous revision: 1.69
done
Comment 3 Christine Caulfield 2007-09-17 09:36:04 EDT
Added to RHEL5
Checking in commands.c;
/cvs/cluster/cluster/cman/daemon/commands.c,v  <--  commands.c
new revision: 1.55.2.11; previous revision: 1.55.2.10
done
Comment 5 RHEL Product and Program Management 2008-01-21 15:25:29 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Thorsten Scherf 2008-04-12 18:27:42 EDT
I use cman-2.0.83-2.el5, according to the changelog the fix is included here.
The number of expected votes/quorum is not recalculated after I cleanly removed
a node from the cluster with cman_tool leave remove (after I manually killed
fenced, ccsd since this was the only I to run cman_tool leave remove).
 
Comment 12 Christine Caulfield 2008-04-14 05:31:28 EDT
Thorsten is right, this fix was broken by 1.55.2.13.
Comment 13 Christine Caulfield 2008-04-14 09:16:01 EDT
The fix is in git, for master & STABLE2 branches:

commit 529c79ee350e06e14075dd2006b34920bacdb4bb
Author: Christine Caulfield <ccaulfie@redhat.com>
Date:   Mon Apr 14 14:01:13 2008 +0100

[CMAN] Save the new expected_votes when a node is removed
Comment 15 Christine Caulfield 2008-04-14 12:30:06 EDT
Now in RHEL52 branch:

commit 4f5e3c542d1e08f3acfd61882437ec839e3658b0
Author: Christine Caulfield <ccaulfie@redhat.com>
Date:   Mon Apr 14 17:28:33 2008 +0100

[CMAN] Save the new expected_votes when a node is removed
Comment 19 errata-xmlrpc 2008-05-21 11:57:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html

Note You need to log in before you can comment on or make changes to this bug.