Bug 271741 - smartd-conf.py should allow customization of parameters
Summary: smartd-conf.py should allow customization of parameters
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: smartmontools
Version: 7
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tomas Smetana
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-31 15:13 UTC by Matthew Mastracci
Modified: 2007-11-30 22:12 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-09-25 08:28:27 UTC


Attachments (Terms of Use)

Description Matthew Mastracci 2007-08-31 15:13:58 UTC
Description of problem:

smartd-conf.py currently hardcodes the parameters to each harddrive.  To
customize the parameter, you need to disable autogeneration of the smartd.conf
file.  It would be easier if a user could specify global flags if
/etc/sysconfig/smartmontools:

smartctl_opts="-t -l error -l selftest -s
(O/../.././(00|06|12|18)|S/../.././01|L/../../6/03)"

The above line requests more detailed monitoring of SMART flags, plus automatic
offline/extended tests throughout the day.

Version-Release number of selected component (if applicable):

smartmontools-5.37-3.fc7

How reproducible:

100%

Additional info:

Can provide a patch if needed.

Comment 1 Tomas Smetana 2007-09-03 09:05:31 UTC
It can be done quite easily but do you really think it's useful?  What's easier
on editing /etc/sysconfig/smartmontools than /etc/smartd.conf?  The script is
intended for inexperienced users to create a basic configuration for them.  If
you're able to configure smartd yourself, why do you need to have the config
file autogenerated?

Comment 2 Matthew Mastracci 2007-09-03 14:55:05 UTC
I agree that it doesn't take an overwhelming amount of work to modify the
smartd.conf file, but it ends up being a bit tedious on machines with more than
5 hard drives.  It also makes it easier and less error-prone when installing new
drives or modifying global configuration parameters.

It also makes it easier to modify the smartd templates on more than one machine.
 Currently, rolling out a change to run automatic tests on HDDs across 10
machines requires editing 10 files x # of hard drives.  With the change, it
would require 10 scp calls to write a new, identical config file.

I don't currently see a need for more granular option configuration - this would
be for configuring global defaults only.  If someone requires per-hard-drive
configuration, it would be just as easy to modify smartd.conf.


Comment 3 Tomas Smetana 2007-09-04 12:16:45 UTC
You should be able to add the parameters into /etc/sysconfig/smartmontools --
optional variable smartd_conf_opts.  The change will be present in the next update.

Comment 4 Fedora Update System 2007-09-04 22:07:06 UTC
smartmontools-5.37-3.2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Matthew Mastracci 2007-09-04 22:24:46 UTC
Tested, works as expected with and without the following option in
/etc/sysconfig/smartmontools:

smartd_conf_opts="-H -m root -t -l error -l selftest -s
(O/../.././(00|06|12|18)|S/../.././01|L/../../6/03)"


Comment 6 Fedora Update System 2007-09-25 08:28:26 UTC
smartmontools-5.37-3.2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.