Bug 27190 - parm tw acts as a line wrapper rather than an unindent
Summary: parm tw acts as a line wrapper rather than an unindent
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL: gsimpson@mountaincable.net
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-12 18:43 UTC by Glenn Simpson
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 18:59:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Glenn Simpson 2001-02-12 18:43:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


Setting the vim parameter 'tw' specifies the number of columns to unindent
a line.  This has been true on Solaris, SCO, and past releases of RH Linux.

If I 'set tw=4', in Fisher, then vim with line wrap on a white space that
is greater than column 3.

Reproducible: Always
Steps to Reproduce:
1.In vim, use the command 'set tw=4'
2.Use input mode and enter a line of text with words separated by a space
3.If the space is beyond equal to or beyond the value of 'tw' the  space
will replaced with a new line.

This will also happen if you set 'tw' in ~/.exrc
	

Actual Results:  See above.  'tw' seems to be functioning as 'line wrap'
limit and not the size of an unindent action which it has always been.
If tw=4 and The line 'Mary had a little lamb' is input the screen will show
Mary
had
a
little
lamb

Expected Results:  setting tw to a value should cause an autoindented line
to unindent by the number of columns specified by 'tw' (or the left margin
if  the cursor is at a column that is less than the value of tw from the
left margin)

 If tw=6 and the cursor is at col 24, pressing CNTL-D would cause the
cursor to move to col 18.  Similiar if tw=4 and the cursor is initially at
colmn 28, pressing CNTL-D three times would move the cursor to col 16

Comment 1 Glenn Simpson 2001-02-12 18:59:53 UTC
My apology.  I had the wrong parameter.  Please close this report as "not a bug"


Note You need to log in before you can comment on or make changes to this bug.