This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 27193 - WinMe installation corrupted
WinMe installation corrupted
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-12 14:05 EST by Chris Runge
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 15:36:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2001-02-12 14:05:37 EST
Fisher

WinMe is installed on /dev/sda1. I create standard partitions for /boot, /,
swap, /usr, etc.

Graphical install. Use Disk Druid to create partitions. I say that I want
lilo installed on /dev/sda2 (/boot) partition, not on the MBR. Disk Druid
apparently leaves /dev/sda1 as the active partition, so when I reboot it
should start WinMe. This doesn't happen. Instead, a cursor appears and the
system hangs. If I change the active partition to /dev/sda2 then I can
access Linux, but never WinME.

Interestingly, this doesn't happen if Win2K is on /dev/sda1 instead of
WinME. I have no problems here. Win2K boots fine. I can then change the
active partition to /dev/sda2 and add an entry for Win2K in /etc/lilo.conf
and I have no problems.

Also, I did a text install and used fdisk to create my partitions. WinMe is
not destroyed when I do this.
Comment 1 Michael Fulbright 2001-02-13 23:24:17 EST
Can QA install a windows Me box to verify this on? I do not have access to
Windows anything.
Comment 2 Brock Organ 2001-02-14 17:26:03 EST
do you have this same problem if you choose to NOT install lilo (but rather boot
from floppy disk) ...?

We have not seen this problem with DOS & Windows 95 & 98 in internal testing,
but have not tried Windows ME yet...
Comment 3 Brock Organ 2001-02-14 17:27:17 EST
additionally, are you able to dual boot linux & ME if you install LILO to the
MBR of sda ...?
Comment 4 Chris Runge 2001-02-15 11:23:59 EST
I'll see what I can do. I'm out on sales calls for awhile so it may be awhile
before I can test this.
It may be that the next tests I do are w/ RC1

Something else that I forgot to mention w/ re to this problem. After it occurs I
can't even boot from a WinMe rescue floppy. The light blinks on and off a few
times then the system halts. I certainly don't expect us to fix an MS problem,
but I think the problem might be indicative of what is going on--my guess is
that we are touching the MBR somehow even though I tell it otherwise: once I
wipe the MBR (cat /var/log/messages > /dev/sda; reboot) I can boot the WinMe
floppy w/o any problems. (I still have to reinstall WinME)
Comment 5 Chris Runge 2001-02-17 09:23:22 EST
brief update: if I don't install LILO (but I do create a boot disk) the problem
still occurs
Comment 6 Chris Runge 2001-02-17 11:08:35 EST
another test, as requested: If I install LILO on the MBR LILO works but I still
can't access WinMe -- it hangs when I choose that option off the lilo menu
Comment 7 Michael Fulbright 2001-02-19 12:10:17 EST
Please try this out Brent.
Comment 8 Brent Fox 2001-02-19 15:36:51 EST
I have seen Windows ME and Red Hat machines dual boot correctly, but they were
all with IDE disk drives.
Comment 9 Brent Fox 2001-02-19 19:46:44 EST
I tested this with SCSI drives today and could not reproduce.

Note You need to log in before you can comment on or make changes to this bug.