Bug 27194 - problems with Nvidia GeForce 2 Pro during install
Summary: problems with Nvidia GeForce 2 Pro during install
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-12 19:17 UTC by Chris Runge
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-22 15:44:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Runge 2001-02-12 19:17:57 UTC
Fisher

Graphical install...

1) the card is detected properly as an "NVIDIA GeForce 2 (generic)" during
the X configuration phase. However, it says it only has 256KB of memory
when it has 64MB.

2) If I test the configuration during the install (1024x768x16 -- the
standard/default) the screen goes black then returns to a partially drawn X
screen (hard to describe); pressing any key from this point repeats this
process (black then partially drawn screen). There is no way to exit this
and a reboot is needed.

Ctrl-Alt-F1 shows this:

Gtk-WARNING **: cannot open display: :9
Gdk-ERROR **: Fatal IO error 104 (Connection reset by peer) on X server :9.

------------------------------

text install ...

I am unable to successfully test an X config during the installation phase
.. it always says that an error occurred. Other virtual consoles did not
enlightenment as to the problem. If I still the X config and reboot into
the OS then startx works fine without any modifications or without running
Xconfigurator

Comment 1 Brock Organ 2001-02-12 21:06:24 UTC
1) Using a similar card ("NVIDIA GeForce 256 (generic)"), my card is detected @
4Mb instead of 32Mb ... :(

2) did you test your X configuration from a cdrom based install?  If so, are you
able to see the same behavior when testing X from a network based install? 
(There may be issues with slow cdrom io in fisher that causes nastiness at the
test screen)



Comment 2 Chris Runge 2001-02-13 02:38:01 UTC
If I remember correctly all installs were NFS installs.

The memory issue doesn't bother me (I don't even see memory listed anywhere in
the config file and it appears to be autodetected fine when I startx); it just
looks bad.

The test issue does bother me... with 3 different video cards (Radeon 64MB,
Voodoo5 5500 AGP, and the GeForce 2 Pro) I have yet to get a successful video
test during an install. (I've opened separate problems for the other 2 video
cards).

Comment 3 Brent Fox 2001-02-17 07:52:43 UTC
I have a Radeon 64MB in my test machine at work and the Radeon problems have
been resolved.  I'll look into the Voodoo5 and GeForce issue.  Did you try the
'nofb' option?  Also, try passing vga=788 at the boot prompt.  In Fisher, the
vga mode is being incorrectly set to vga=787, which causes problems with some
video cards.

Comment 4 Chris Runge 2001-02-17 16:22:13 UTC
one thing about the Voodoo 5 test during the install: it isn't that I have a
problem when I test it--it is that there is no option to test it

I'm checking the vga=788 suggestion now

Comment 5 Chris Runge 2001-02-17 16:31:25 UTC
at the boot prompt I issued linux vga=788

this gave marginally better results: when I select test the screen flashes a few
times, then returns me to the original screen (the one with the test button) --
the system isn't frozen, but I can't get a decent test either


Comment 6 Chris Runge 2001-02-17 16:53:45 UTC
'nofb' option gives same result as passing vga=788

Comment 7 Chris Runge 2001-02-18 13:08:35 UTC
I went back and tested this under RHL 7--there were no problems (this was with a
graphical install off a CD-ROM)

Comment 8 Brent Fox 2001-02-20 04:54:30 UTC
I think in RHL 7 that we did not draw the 'Test' button if a Voodoo card was
detected because they almost always locked up the machine.  I haven't gotten my
hands on a Voodoo card at work yet.  From your last few posts, it's not clear
which card you are using.  Can you clarify?

Comment 9 Chris Runge 2001-02-22 02:18:42 UTC
sorry for the confusion -- all tests were done with the GeForce card. I just
mentioned the Voodoo 5 and the Radeon as an aside to indicate that I had
problems with those as well. If I get a chance soon I'll test the GeForce card
vs. RC1

Comment 10 Chris Runge 2001-02-22 15:44:08 UTC
this bug is fixed in Wolverine. The amount of memory on the card is correctly
identified and the video card test works.


Note You need to log in before you can comment on or make changes to this bug.