Bug 27195 - lots of errors from printtool
lots of errors from printtool
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-12 14:39 EST by Jay Berkenbilt
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-14 20:25:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Berkenbilt 2001-02-12 14:39:47 EST
This problem was reported in 26011 but that bug report contained too much
information that ended up being unrelated.  I'm resubmitting the part of
that bug that related to printconf-gui only.

Whenever I run printtool (printconf-gui), clicking "New" results in

*** Bad argument: #<subr aref>, 0, 2
*** Bad argument: #<subr aref>, 0, 2
*** Bad argument: #<subr aref>, 0, 2
*** Bad argument: #<subr aref>, 0, 2
*** Bad argument: #<subr aref>, 0, 2


as does just about anything else.  I'm not sure whether or not this is
actually interfering with setting up a printer.  I still can't print
from RedHat 7.1 beta, but I haven't investigated that enough to send
in a useful bug report about it.  In any case, just about any action
causes numerous instances of the above to be issued.

This happens every time.  I can reproduce this reliably by running
from an environment in which my .xinitrc/.xsession starts xterms
rather than using a session manager.  I believe I have also reproduced
it as a vanilla user logging in under gdm with the default gnome
desktop.
Comment 1 Glen Foster 2001-02-12 18:03:05 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Crutcher Dunnavant 2001-02-14 02:21:08 EST
What can I say? I can't reproduce this error, I don't know why you are getting
it, and I suspect its a console-helper/gtk/X interaction. I am going to mark
this needinfo, and if you can get anything more about how to isolate this, post it.
Comment 3 Jay Berkenbilt 2001-02-14 11:11:00 EST
Fair enough.  It works for me logged in directly as root.  For what it's worth,
I dug through all those menus looking for something to configure printers and
couldn't find anything. I just ended up running printtool from the commandline.

I still can't get printing to work through my old external JetDirect device that
I inherited from my company when we upgraded to 100 Mbps.  Since I've never used
lprng before, I haven't gone for enough to report a bug.  My goal will be to get
printing to work from my machine, figure out the source of the problems I've
reported here, and report back.
Comment 4 Preston Brown 2001-02-14 20:25:15 EST
should be working now.
Comment 5 Jay Berkenbilt 2001-02-15 00:11:28 EST
I've taken the liberty to mark this bug as closed.  It doesn't have anything to
do printconf-gui.  These error messages were coming from my window manager.  I
use sawfish with a highly customized profile.  printconf-gui exercises some bug
in my sawfish profile.  My mistake for posting this as a printconf-gui bug. 
Sorry to waste everyone's time on this.  It was a complete false alarm.

Note You need to log in before you can comment on or make changes to this bug.