Bug 272201 - [Xen] vmalloc/vfree on HVM Guest/IA64 does untolerate performance.
[Xen] vmalloc/vfree on HVM Guest/IA64 does untolerate performance.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.2
ia64 Linux
urgent Severity high
: rc
: ---
Assigned To: Bill Burns
Martin Jenner
GSSApproved ResolveBy=03/31/2008
: OtherQA, ZStream
Depends On:
Blocks: 246139 232924 276501 296411 372911 433616
  Show dependency treegraph
 
Reported: 2007-08-31 12:31 EDT by Flavio Leitner
Modified: 2009-06-19 20:47 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:54:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Leitner 2007-08-31 12:31:50 EDT
Description of problem:

Windows guest/IA64 have a bad network performance due to lack of 
optimizations on ptc.e emulation and on vtlb size.

This issue is already fixed by part of following patch
changeset: [IA64] Speedup ptc.e emulation
http://xenbits.xensource.com/ext/ia64/xen-unstable.hg?rev/834ac63f4894

changeset: [IA64] Make MMU setting of domVTi configurable
http://xenbits.xensource.com/ext/ia64/xen-unstable.hg?rev/5b19839d0365

changeset: [IA64] Shrink vtlb size
http://xenbits.xensource.com/ext/ia64/xen-unstable.hg?rev/f317c27973f5


Version-Release number of selected component (if applicable):
RHEL5.1 beta

How reproducible: 
Always

Steps to Reproduce:
Test with ttcp(network benchmark)
execute ttcp -u -t -l65000 -n75000 xx.xx.xx.xx

patches      VHPT size                 Throughput (KB/sec)
-----------------------------------------------------
not applied  16M                       47483.96
applied      2M(vti_vhpt_size=1024)    79691.03
  
Actual results:
Network Performance is worse.

Expected Results:
Network Performance is fine.
Comment 1 Issue Tracker 2007-09-02 23:15:36 EDT
Hi Fabio,
Thank you for your escalating for 5.2. 

As to z-stream, I'll clarify it again. I just requested because I saw the
following comment in their report.

> Fix Target: 5.1.
> errata Request: Yes

Actually, there is no explanation why they cannot wait 5.2. Though I
guess, they need to provide this fix for the customer having 5.1.z
subscription. Despite my guess, I'll have them explain the need.


This event sent from IssueTracker by mmatsuya 
 issue 130237
Comment 3 Larry Troan 2007-09-18 13:36:15 EDT
This is a feature, not a bug. Windows is not officially supported as a guest on
RHEL at this time. 

Targeting 5.2 and will discuss other possible options with Brian Stein en
company. Currently, we have no mechanism to deliver a feature between minor updates.
Comment 4 Daniel Riek 2007-10-31 15:36:06 EDT
PM ACK for 5.2
Comment 5 Jay Turner 2007-11-22 08:25:13 EST
QE ack for RHEL5.2.  Appears we have patches and reproducer mentioned in bug intro.
Comment 6 Larry Troan 2007-11-29 07:30:34 EST
Can we get a comment from Development on whether this will be in RHEL5.2. We
already have PM and QA ACKs.

Per Jan Holzer,
> (2) When and where will the mentioned para-virtualized drivers become 
> available (also for customers)? Will they be free of charge?
The goal is to deliver the para-virtualized drivers for RHEL (RHEL3/4/5) by the
end of this year (2007) , the Windows para-virtualized drivers are currently
targeted to be available in early 2008. The drivers are currently tested by a
number of customers and if you have customers interested in testing a beta
version of the (RHEL) drivers we'd be than happy to work with them and provide
the drivers.

Fujitsu, is this a problem with the new drivers? If so, this issue would be a
bug in a promised feature.
Comment 7 Bill Burns 2007-12-10 08:49:40 EST
Setting needinfo for clarification on question in comment #6,
Comment 8 KUWAMURA Shin'ya 2007-12-10 21:18:04 EST
This issue is unrelated to drivers. Even if para-virtualized drivers is used,
the problem still remains. Thus we need these patches.
Comment 11 Brian Stein 2007-12-18 16:24:12 EST
Patch was previously POSTED but needs to be reworked against 5.2, will be POSTED
soon.
Comment 12 Bill Burns 2008-01-03 14:22:20 EST
Changing component to kernel-xen.
Comment 13 Don Zickus 2008-01-23 17:07:22 EST
in 2.6.18-73.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 15 KUWAMURA Shin'ya 2008-01-31 03:04:24 EST
kernel-xen-2.6.18-73.el5 is OK.
We confirmed the source code and the test passed.
Comment 28 errata-xmlrpc 2008-05-21 10:54:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.