Bug 272361 - taglib: RFE: svn update?
taglib: RFE: svn update?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: taglib (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 12:57 EDT by Rex Dieter
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 16:57:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2007-08-31 12:57:59 EDT
See "Taglib 2-year anniversary coming up" thread:
http://mail.kde.org/pipermail/taglib-devel/2007-July/000720.html
Comment 1 Hans Ecke 2007-09-21 12:40:41 EDT
Yes! Please update the fedora copy of taglib to current SVN. Version 1.4 is 
more than 2 years old and has a lot of bugs. For one of my media files it 
caused Amarok to allocate all of physical memory and crash. How do you find the 
problematic file among 10s of thousands?

I'm now running SVN taglib on all my machines (more than 10: FC5 and F7, 32 bit 
and 64 bit, many users) and it is way more stable. Also, there are no ABI 
changes as far as I could see: client apps do not need to be recompiled.
Comment 2 Hans Ecke 2007-09-21 12:42:08 EDT
Is Aurelien's correct email agauret@free.fr or bompard@fedoraproject.org? RPM 
changelog for taglib says the latter. I hope he receives edits to this bug....
Comment 3 Rex Dieter 2007-09-21 12:55:21 EDT
Ugh, I just tried sending mail to both, and got bounces.
Comment 4 Hans Ecke 2007-09-21 15:08:48 EDT
Note I mistyped the first email, its (as written above) gauret@free.fr.

aurelien@bompard.org might also work. http://gauret.free.fr/spip/ might hold 
clues, but my french is pretty weak these days.
Comment 5 Aurelien Bompard 2007-09-24 10:38:51 EDT
Hi guys,
SVN-based builds should arrive in Rawhide. In the meantime they are available here:
http://koji.fedoraproject.org/packages/taglib/1.5/0.3.20070924svn.fc8/

Please test and tell me if anything goes wrong.

(and btw please avoid pasting my email adresses in bugzilla, comments are not
protected and I'm having enough of a hard time dealing with spam already...)
Comment 6 Hans Ecke 2007-09-24 14:24:00 EDT
Thank you! Builds and seems to work fine (according to simple tests) on 
fc5-x86_64, f7-x86_64 and f7-i386. Will write another comment if I find a 
problem.

And sorry about the email addresses. Won't happen again.
Comment 7 Ralf Ertzinger 2007-09-27 15:14:29 EDT
The devel package seems to miss some files:

tag.h references taglib_export.h, which is not in the package.
Comment 8 José Matos 2007-09-27 15:41:29 EDT
I have the same problem. I tried to build the latest version of tellico for 
F-8.

/usr/include/taglib/tstring.h:25:27: error: taglib_export.h: No such file or 
directory

Just for reference the error message is here (for limited time):
http://koji.fedoraproject.org/koji/getfile?taskID=176801&name=build.log
Comment 9 Rex Dieter 2007-09-27 15:50:32 EDT
Yeah, looks like an easyfix, I'll whip up a patch.
Comment 10 Rex Dieter 2007-09-27 16:01:57 EDT
The old auto*-based buildsys is broken, cmake-build works.  I'll go patch it
accordingly.
Comment 11 Rex Dieter 2007-09-27 16:16:56 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=177093

* Thu Sep 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.5-0.4.20070924svn
- use cmake, fixes "taglib_export.h not included" (#272361#c7)
Comment 12 Rex Dieter 2007-09-27 16:27:22 EDT
OK, let's try that again, without missing build deps this time.

http://koji.fedoraproject.org/koji/taskinfo?taskID=177107

* Thu Sep 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 1.5-0.5.20070924svn
- -BR: automake
- +BR: zlib-devel
Comment 13 Aurelien Bompard 2007-10-07 13:40:52 EDT
This build works fine for me, and it looks like it's been published in RawHide.
Can we close this bug, or is there something else to do ?
Comment 14 Rex Dieter 2007-11-20 16:57:54 EST
close.

Note You need to log in before you can comment on or make changes to this bug.