Bug 272841 - mod_python crahes httpd
mod_python crahes httpd
Status: CLOSED DUPLICATE of bug 254241
Product: Fedora
Classification: Fedora
Component: mod_python (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 14:35 EDT by Greg Dickie
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 17:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Dickie 2007-08-31 14:35:30 EDT
Description of problem:

It seems that if I have mod_python installed these days then apache crashes as
soon as it tries to access the module


Version-Release number of selected component (if applicable):

httpd-2.2.4-9
mod_python-3.3.1-4

How reproducible:

Going to any page seems to crash it


Steps to Reproduce:
1. Go to any page
2.
3.
  
Actual results:

apache segfaults

Expected results:

apache does not segfault

Additional info:

(gdb) run -X
Starting program: /usr/sbin/httpd -X
[Thread debugging using libthread_db enabled]
[New process 24846]
[New Thread -1209108720 (LWP 24846)]
httpd: Could not reliably determine the server's fully qualified domain name,
using 127.0.0.1 for ServerName

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209108720 (LWP 24846)]
0x01d7a782 in python_handler (req=0xb95a1ec8, phase=0x1d7c1c1
"PythonInitHandler") at mod_python.c:1549
1549        conf = (py_config *) ap_get_module_config(req->per_dir_config, 
(gdb)
Comment 1 Greg Dickie 2007-08-31 14:55:24 EDT
gdb) where
#0  0x24871782 in python_handler (req=0xb94a1e70, phase=0x248731c1
"PythonInitHandler") at mod_python.c:1549
#1  0x2487203a in PythonPostReadRequestHandler (req=0xb94a1e70) at mod_python.c:2898
#2  0xb7f802de in ap_run_post_read_request (r=0xb94a1e70) at
/usr/src/debug/httpd-2.2.4/server/protocol.c:1636
#3  0xb7f82784 in ap_read_request (conn=0xb9497fe0) at
/usr/src/debug/httpd-2.2.4/server/protocol.c:1011
#4  0xb7f9afae in ap_process_http_connection (c=0xb9497fe0) at
/usr/src/debug/httpd-2.2.4/modules/http/http_core.c:177
#5  0xb7f9680d in ap_run_process_connection (c=0xb9497fe0) at
/usr/src/debug/httpd-2.2.4/server/connection.c:43
#6  0xb7f9690c in ap_process_connection (c=0xb9497fe0, csd=0xb9497e48) at
/usr/src/debug/httpd-2.2.4/server/connection.c:178
#7  0xb7fa2512 in child_main (child_num_arg=<value optimized out>) at
/usr/src/debug/httpd-2.2.4/server/mpm/prefork/prefork.c:640
#8  0xb7fa2784 in make_child (s=0xb910e3f0, slot=0) at
/usr/src/debug/httpd-2.2.4/server/mpm/prefork/prefork.c:680
#9  0xb7fa3699 in ap_mpm_run (_pconf=0xb910c550, plog=0xb913a608, s=0xb910e3f0)
at /usr/src/debug/httpd-2.2.4/server/mpm/prefork/prefork.c:956
#10 0xb7f7a22a in main (argc=-1190091320, argv=0xb91be6e8) at
/usr/src/debug/httpd-2.2.4/server/main.c:717
Comment 2 Joe Orton 2007-08-31 17:19:27 EDT

*** This bug has been marked as a duplicate of 254241 ***

Note You need to log in before you can comment on or make changes to this bug.