This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 27311 - gdb can't handle more than 32 pthreads
gdb can't handle more than 32 pthreads
Status: CLOSED DUPLICATE of bug 39070
Product: Red Hat Linux
Classification: Retired
Component: gdb (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-12 19:47 EST by Len Widra
Modified: 2007-03-26 23:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-10 10:08:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Len Widra 2001-02-12 19:47:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


GDB craps out with more than 32 pthreads.  See the "Steps to Reproduce".

Reproducible: Always
Steps to Reproduce:
Compile this program and just try to run it under gdb:

/* compile with cc -o pthread_test pthread_test.c -lpthread */

#include <pthread.h>

void *pthread_test(void *);

main()
{
        int i;
        pthread_t tid;

        for(i=0;i<100;i++)
        {
                pthread_create(&tid,NULL,pthread_test,NULL);
        }
}

void *
pthread_test(void *arg)
{
        sleep(100);
}



Actual Results:  GDB says:
"Cannot find thread 33: invalid thread handle"

Expected Results:  The darn thing should have allowed all 100 threads to be
created, and
it should have allowed me to debug them.

This has been broken for a while (you can reproduce it on earlier
releases).
I keep hoping that it'll get fixed in one of these releases or patches; but
it's
just festering.  I'm hoping that was for lack of an official bug report.
Comment 1 Trond Eivind Glomsrxd 2001-02-13 18:43:10 EST
GDB has plenty of problems with pthreads....
Comment 2 Len Widra 2001-02-14 02:12:12 EST
> GDB has plenty of problems with pthreads....

OK, I can believe that.  But I don't know
what your point is.  Could you clarify?
Thanks.
Comment 3 Don Howard 2001-02-14 21:09:13 EST
Kevin Buettner has proposed a patch for this.  It is non-trivial and has not yet
been merged into the main source tree.  You can find his patch at:

http://sources.redhat.com/ml/gdb-patches/2000-10/msg00014.html
Comment 4 Don Howard 2001-02-16 13:43:11 EST
This issue will be fixed when the patch mentioned above is merged into gdb.  You
can apply it localy, if you need it now.
Comment 5 Len Widra 2001-02-16 16:25:05 EST
I applied the patch to a more recent copy of gdb, and it seems to do the trick,
(though as was mentioned there are lots of other bugs with gdb+pthreads).
Thanks very much.
Comment 6 Trond Eivind Glomsrxd 2001-08-10 10:11:09 EDT
This was closed as deferred for RHL 7.1 - the changes has been added to GDB CVS
since then, however.

*** This bug has been marked as a duplicate of 39070 ***

Note You need to log in before you can comment on or make changes to this bug.