Bug 27353 - FSTAB options ignored by mount
FSTAB options ignored by mount
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 01:35 EST by Bill Winspur
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 13:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Winspur 2001-02-13 01:35:24 EST
I thought I'd entered this report yesterday, but didnt see it in the db so 
this is a repeat entry.... I had a problem executing scripts stored on a 
cdrom, which was due to my cdrom being mounted with the noexec option. The 
fstabe entry looks like this:
  /dev/hdb/   /mnt/cdrom  iso9660 exec,noauto,ro,user,suid    0 0
The command 'mount /dev/hdb' produced the following line in /etc/mtab:
  /dev/hdb /mnt/cdrom iso9660 ro,noexec,nodev 0 0

It appears that the exec option in the fstab is being ignored.

The following, explicit mount command:
 'mount -t iso9660 /dev/cdrom /mnt/cdrom
produced the following line in /etc/mtab:
 /dev/hdb /mnt/cdrom ro 0 0

After this I was able to execute scripts stored on the cdrom, so the 
problem is not urgent for me.

I did not see this problem, which seeems more like a bug than a feature, 
in the 'Redhat Linux, 6.2, mount' selection from the db, but if it has 
already been covered under wider scope, my apologies.
Comment 1 Rob Shelley 2001-07-02 13:52:52 EDT
I have a similar problem when trying to mount a volume on a NetWare fileserver. 
As per the ncpmount man page you can use mount option "ipserver=" to connect via
TCP/IP without configuring IPX on the linux box.  The option is supposed to
correlate with a -A switch on the ncpmount command line.  But when mount calls
ncpmount, the command line is missing that switch.  Since I haven't configured
IPX on this box it returns some sort of error relating to not being able to find
the server even though the server is listed in the hosts file.  This happens if
the option is listed in the fstab file, or it also happens if I try the mount
command line manually.  Either way it's like it misses the ipserver option.  If
I enter the ncpmount line manually with the -A option, it doesn't have any
problems mounting the file system.
Comment 2 Bernhard Rosenkraenzer 2002-01-17 14:13:20 EST
This works correctly in 7.2

Note You need to log in before you can comment on or make changes to this bug.