Bug 27371 - Many shadow utils and other programs do not grok md5
Summary: Many shadow utils and other programs do not grok md5
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils   
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-13 09:19 UTC by Mike A. Harris
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-12 12:04:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2001-02-13 09:19:49 UTC
If you use the "chpasswd" utility that comes with shadow-utils it does
not generate md5 passwords if the system is using md5 passwords, which
really sucks considering everyone uses the default md5 passwords now.

There is a good chance that all system password utilities do not grok
md5 passwords.

Create a list of passwords like this:

mail:newpassword
uucp:potato
news:microsoftsucks

Then run:
chpasswd < userlist

It adds the passwords to the system alright, but not md5'd.  Sounds like
the system passwd utils should have a feature audit.  Reason I stumbled
on this was I was trying to find a solution for someone wanting to add
numerous users to the system using shadow+md5 and I've so far been unable
to..  ;o(

Kindof important for ISP's, univ's, etc.. IMHO.

Comment 1 Mike A. Harris 2004-07-12 12:04:29 UTC
chpasswd still 3 years later, generates non-md5 passwords when the
system is set to use MD5 by default...  (tested on Fedora Core 1)

Setting status to "WONTFIX", as it's been 3 years since I submitted
this issue, and the problem still remains.  It seems low priority
enough that it is unlikely we will implement this.




Note You need to log in before you can comment on or make changes to this bug.