Bug 27375 - dhcpcd can`t get IP infos at first attempt
dhcpcd can`t get IP infos at first attempt
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 06:49 EST by Marc Schmitt
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Schmitt 2001-02-13 06:49:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-3 i686)


When using dhcpcd only to determine the IP infos (pump can`t set
hostnames), dhcpcd is not able to send a correct dhcp request at the first
attempt.
I.e. it sends a request with the clientID 00:00:00:00:00:00, instead of the
real MAC address of the NIC.
The problem did not change with the lastest kernel (2.2.17-14) nor with the
latest dhcpcd version (1.3.19pl6-1).
The second attempt will work, resulting in a dhcp request with the correct
MAC address. It looks like the kernel module loader loads the module for
the NIC (3c90x) by the time dhcpcd is called in ifup but then fails to
provide the MAC address to dhcpcd.

Reproducible: Always
Steps to Reproduce:
1. ifdown eth0 ; rmmod 3c90x
2. /sbin/dhcpcd -R -B -H eth0

	

Actual Results:  dhcp server log: dhcpd: no free leases on network
129.132.10.0 match 00:00:00:00:00:00

On the client: 3Com 3c90x Version 1.0.0i 1999 (linux_drivers@3com.com)
timeout after 60s

Expected Results:  dhcp server log:
dhcpd: DHCPDISCOVER from 00:b0:d0:7b:b6:6c via hme0
dhcpd: DHCPOFFER on 129.132.10.102 to 00:b0:d0:7b:b6:6c via hme0
dhcpd: DHCPREQUEST for 129.132.10.102 from 00:b0:d0:7b:b6:6c via hme0
dhcpd: DHCPACK on 129.132.10.102 to 00:b0:d0:7b:b6:6c via hme0



Interestingly, doing step 2. with pump works w/o any problems.

An easy workaround is to use pump first and dhcpcd the next line.
Comment 1 Bill Nottingham 2001-02-13 18:50:52 EST
Does it work better if you use the 3c59x driver?
Comment 2 Marc Schmitt 2001-02-14 05:26:43 EST
Indeed, the problem disappears when using the module 3c59x instead of 3c90x.
Comment 3 Elliot Lee 2001-08-08 01:03:04 EDT
Sounds like already resolved.

Note You need to log in before you can comment on or make changes to this bug.