Bug 27393 - NMI Watchdog detected LOCKUP on CPU1 -- mouse dies
Summary: NMI Watchdog detected LOCKUP on CPU1 -- mouse dies
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-13 15:28 UTC by Chris Runge
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-19 15:40:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Runge 2001-02-13 15:28:58 UTC
Fisher

if I start X, then exit or switch to VC I see this:

NMI Watchdog detected LOCKUP on CPU1, registers:
CPU:    1
EIP:    0010:[<e0890c16>]
EFLAGS: 00000056
eax: 00000000   ebx: 00000020   ecx: 00000002   edx: 00000002
esi: 00000006   edi: 00000001   ebp: 00000003   esp: de229e7c
ds: 0018   es: 0018   ss: 0018
Process gpm (pid: 860, stackpage=de229000)
.
.
.


The mouse then dies, both under X and under a VC. service gpm restart does
not revive it; I must reboot. 

The system :

SuperMicro 370DE6 motherboard (based on ServerWorks III HE-SL chipset)
2x 1Ghz Pentium III
512 MB RAM
MS Intellimouse Explorer connected to USB port

cat'ing /proc/interrupts displays a non 0 value for NMI

Marking as high since a reboot is req'd to get the mouse to work again

Comment 1 Glen Foster 2001-02-13 20:22:30 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 2 Michael K. Johnson 2001-02-14 00:49:40 UTC
Please try the next kernel we release and see if it fixes the
problem.  If not, we need a decoded oops messages -- you need
to run the whole oops message through the ksymoops program so
that it is symbolically decoded.

Comment 3 Chris Runge 2001-02-15 16:30:04 UTC
interesting.... I had a MS Force Feedback 2 joystick connected to one of the USB
ports in addition to the mouse. If I remove the joystick the problem appears to
go away.

Comment 4 Chris Runge 2001-02-15 16:33:53 UTC
see 25849 for an example of how the joystick caused problems with Xconfigurator

Comment 5 Michael K. Johnson 2001-02-15 17:07:07 UTC
Nalin, does this resemble what you saw?

Comment 6 Michael K. Johnson 2001-02-20 17:17:21 UTC
We still need that ksymoops output...

Comment 7 Nalin Dahyabhai 2001-02-20 17:25:15 UTC
Yes, this resembles what I saw.  I've upgraded to a newer kernel since then, so
the fixed ksymoops wouldn't give you any useful information.  Will try to
reproduce again today.

Comment 8 Michael K. Johnson 2001-03-01 03:44:35 UTC
Seems to resemble latest behavior in bug #23670


Comment 9 Pete Zaitcev 2001-03-05 23:52:08 UTC
So, where is a meaningful oops report?

I do not have a joystick and everything
works fine without one (I have RIO-600
and floppy on the same chain).
I _suspect_ that something may be up with
having several HID devices, or a joystick
specifically. But I need solid information
before I can try fixing anything.



Note You need to log in before you can comment on or make changes to this bug.