This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 273961 - Miro fails to install
Miro fails to install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
7
All All
medium Severity urgent
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-01 12:02 EDT by Valent Turkovic
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.9.8.1-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 05:46:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2007-09-01 12:02:12 EDT
Description of problem:
Miro fails to install

Version-Release number of selected component (if applicable):
Miro 0.9.8.1-2.fc7

How reproducible:
every time

Steps to Reproduce:
1. yum install Miro
2.
3.
  
Actual results:
# yum install Miro
Loading "presto" plugin
Setting up and reading Presto delta metadata
No Presto metadata available for development
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package Miro.i386 0:0.9.8.1-2.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.5 for package: Miro
--> Processing Dependency: libboost_python.so.2 for package: Miro
--> Finished Dependency Resolution
Error: Missing Dependency: firefox = 2.0.0.5 is needed by package Miro
Error: Missing Dependency: libboost_python.so.2 is needed by package Miro

Expected results:
to install Miro

Additional info:
When will Miro be independent of Firefox package?
Comment 1 Valent Turkovic 2007-09-01 12:03:32 EDT
rawhide updated my Firefox to latest 2.0.0.6 in the last update.
Comment 2 Valent Turkovic 2007-09-19 13:45:08 EDT
I applied all new patches that came in the last few weeks and was hoping to get
Miro to install after that, but no, still nothing :(

# yum install Miro
Loading "presto" plugin
Loading "refresh-updatesd" plugin
Setting up and reading Presto delta metadata
No Presto metadata available for development
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package Miro.i386 0:0.9.8.1-2.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.5 for package: Miro
--> Processing Dependency: libboost_python.so.2 for package: Miro
--> Finished Dependency Resolution
Error: Missing Dependency: firefox = 2.0.0.5 is needed by package Miro
Error: Missing Dependency: libboost_python.so.2 is needed by package Miro


When will you update Miro with support for new Firefox 2.0.0.6 ?
Comment 3 Valent Turkovic 2007-09-27 15:08:00 EDT
do you need some more info or feedback from me in order to fix this bug?
Comment 4 Thorsten Scherf 2007-09-28 03:27:59 EDT
we are actually in the process of moving to a new maintainer for the miro
package, his email is clahey@clahey.net. 
Comment 5 Jack Deslippe 2007-10-30 02:23:07 EDT
I now have this problem as will since firefox 2.0.0.8 is in the official repos.
 I uninstalled miro so firefox would install, and now I can't get miro to work
again.  If I try to yum install miro, it fails because needs firefox 2.0.0.5. 
If I specify no-deps, it installs but crashes on runtime because it looks for
the library it needs in the old firefox directory... 
Comment 6 Alex Lancaster 2007-10-30 06:34:24 EDT
(In reply to comment #5)
> I now have this problem as will since firefox 2.0.0.8 is in the official repos.
>  I uninstalled miro so firefox would install, and now I can't get miro to work
> again.  If I try to yum install miro, it fails because needs firefox 2.0.0.5. 
> If I specify no-deps, it installs but crashes on runtime because it looks for
> the library it needs in the old firefox directory... 

A new version of Miro that has been built against firefox 2.0.0.8 and should
install, you might want to retry and/or delete your cache because sometimes the
mirrors may not have been updated yet, e.g.:

"sudo yum clean all"
"sudo yum install Miro"
Comment 7 Alex Lancaster 2007-11-01 05:46:34 EDT
Rebuilt Miro-0.9.8.1-4.fc7 for firefox 2.0.0.8 should be well and truly
available.  Closing bug.  Feel free to re-open if you still can't update to the
latest Miro.

Note You need to log in before you can comment on or make changes to this bug.