Bug 2741 - Diamond Speedstar A50 incorrectly configured
Diamond Speedstar A50 incorrectly configured
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
:
: 4211 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-11 14:00 EDT by ed.wilts
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-31 16:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ed.wilts 1999-05-11 14:00:54 EDT
XConfigurator incorrectly configures the Diamond Speedstar
A50 board (with SiS 6326 chipset).  Autoprobe does not work.

I told XConfigurator that the board had 8MB Video memory.
The line was written to XF86Config, but was commented out.

Also, the following lines must be added to XF86Config, or
the screen is totally wonky:
option sw_cursor
option no_imageblt
option no_bitblt

I have suggested these settings to dozens of people on
Usenet newsgroups, and all have gotten them to work.   The
defaults are flat out wrong and will not allow X to start.
Comment 1 Preston Brown 1999-08-31 16:05:59 EDT
I have added these settings for your card to the upcoming XFree86
3.3.5 errata release.  If you continue to experience problems with the
card, please reopen this bug.
Comment 2 Preston Brown 1999-08-31 16:17:59 EDT
*** Bug 4211 has been marked as a duplicate of this bug. ***

I have an SiS 6326 AGP 8M video card. It appears to be
supported by XF86, but... I get all kinds of garbage on my
display whenever I enter text, move windows, click on menus,
scrolling, and just about any other action. I am sure this
is because XF86's SVGA graphics server is half-incompatible
with the SiS 6326 AGP card. If you have found a fix please
email me at Kon13@cyberwar.com

------- Additional Comments From   10/07/99 21:17 -------
This bug is NOT fixed.  I tested this with the Redhat 6.1 release, and
the XF86Config file is still not valid.  Autoprobe detects 4096k video
memory, even though I've got 8192k.  However, the VideoRam entry in
XF86Config is commented out, which doesn't allow X to start.

Note You need to log in before you can comment on or make changes to this bug.