Bug 274141 - NM aborts on (I think) receving an invalid D-BUS message
NM aborts on (I think) receving an invalid D-BUS message
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On: 437464
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-01 18:24 EDT by Peter Trenholme
Modified: 2008-04-10 16:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.6.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 16:44:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nm-tool error message and /var/log/messages extract (11.18 KB, text/plain)
2007-09-01 18:24 EDT, Peter Trenholme
no flags Details

  None (edit)
Description Peter Trenholme 2007-09-01 18:24:26 EDT
Description of problem:
After the upgrade to 2.6.23.4-65, I was forced to switch to using the B43 driver
(ndiswrapper no longer works). Now the NetworkManager is crashing after a few
minutes of operation.

Version-Release number of selected component (if applicable): Most recent
release, and the prior release (after I tried a rollback). Sorry, I don't
remember the numbers, and I can't connect using Fedora, so I can;t look them up.


How reproducible:
Every time.

Steps to Reproduce:
1.Boot system with NM started as a service
2.Run this script:
#!/bin/bash
while [ 1 ]; do
  if [ "$(/sbin/pidof NetworkManager) == "" ]; then
    sudo /etc/init.d/NetworkManager start
  else
    sleep 5
  fi
done
3.Wait for the "Passwod" promt to display, enter it, and watch a few minuets . . .
  
Actual results:
Several "[OK]" results from restarting NM

Expected results:
Infinite loop, no output nor prompt

Additional info:
See attached text file for som output from "nm-tool" and an extract from
/var/log/messages
Comment 1 Peter Trenholme 2007-09-01 18:24:26 EDT
Created attachment 184621 [details]
nm-tool error message and /var/log/messages extract
Comment 2 Peter Trenholme 2007-09-04 10:41:08 EDT
RESOLVED, I think

Well, I still believe that NM shouldn't abort on a bad D-BUS message, but my
wireless connection problem seems to have been resolved by changing the the
DRIVER= line in /etc/sysconfig/wpa_supplicant to DRIVER=-Dbroadcom -Dwext.

Apparently there was a wpa_supplicant update concurrent with the kernel update,
and the wpa_supplicant configuration file was changed.
Comment 3 Dan Williams 2008-04-10 16:44:12 EDT
Can you run an 'iwlist eth1 scan' when this happens and report what APs are
around?  This could have been caused by an SSID with certain characters in it,
which is now fixed with NM 0.6.6 in F7-updates.  Please try that version, and if
the same problem appears, reopen this bug.  Thanks!

The  wpa_supplicant config file shouldn't affect the operation of NM, because NM
launches the supplicant with it's own private configuration.

Note You need to log in before you can comment on or make changes to this bug.