Bug 274201 - (fc8-cciss) Switchroot in initrd for cciss fails by nash changes in mkinitrd
Switchroot in initrd for cciss fails by nash changes in mkinitrd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All All
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-09-01 20:31 EDT by Robert Scheck
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 12:28:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot via remote management chip (9.23 KB, image/png)
2007-09-01 20:32 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2007-09-01 20:31:07 EDT
Description of problem:
Looks like opening such bug reports gets tradition :( Peter, some of your 
changes broke the cciss support in the initrd. Switchroot fails for my cciss 
device by one of your more or less recent changes in mkinitrd, likely nash.

Version-Release number of selected component (if applicable):
mkinitrd-6.0.14-1

How reproducible:
Everytime, just install a kernel package when you've got a cciss/HP Smart Array 
system and try to boot it.

Actual results:
Non-booting system because of failed switchroot on cciss caused by some change 
in mkinitrd and/or nash :-(

Expected results:
Would be very nice, if you could fix the broken code very soon ;-)

Additional info:
I'm able to provide any filesystem & path information and system outputs - as 
long as I don't have to reboot the machine for, sorry. I'm also going to attach 
a screenshot, but likely this won't help you much.
Comment 1 Robert Scheck 2007-09-01 20:32:45 EDT
Created attachment 184701 [details]
Screenshot via remote management chip
Comment 2 Robert Scheck 2007-09-01 20:36:40 EDT
mkinitrd-6.0.9-5 is working for me, latest in Rawhide (6.0.14-1) isn't. After 
diffing the the two created initrds, the main difference IMHO is:

--- init.6.0.9-5    2007-09-01 16:22:15.000000000 +0200
+++ init.6.0.14-1   2007-09-01 16:21:49.000000000 +0200
@@ -64,7 +64,7 @@
 mkblkdevs
 resume /dev/cciss/c0d0p3
 echo Creating root device.
-mkrootdev -t ext3 -o defaults,ro cciss!c0d0p2
+mkrootdev -t ext3 -o defaults,ro LABEL=/
 echo Mounting root filesystem.
 mount /sysroot
 echo Setting up other filesystems.

IMHO it looks like the resolving from LABEL=/ to cciss!c0d0p2 is broken once 
more. It also could be another problem with having the exclamation mark within 
the device name. Figguring out and solving until Fedora 8 is up to you ;-)
Comment 3 Peter Jones 2007-09-07 17:42:30 EDT
You don't happen to have a cciss box running something recent that I could ssh
into and test with, do you?  Reboots shouldn't be necessary, but I will need
root access.
Comment 4 Peter Jones 2007-09-11 11:33:08 EDT
Should work in 6.0.16-1 .

Note You need to log in before you can comment on or make changes to this bug.